Bug 1800559 - Knative revision sidebar doesn't show associated deployment or pods
Summary: Knative revision sidebar doesn't show associated deployment or pods
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-07 12:26 UTC by Jaivardhan Kumar
Modified: 2020-05-04 11:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: There isn't any way to navigate to the pods/deployment resource from selecting the knative revision in topology. Consequence: User have to go through multiple clicks to find associated pods/deployment for revision Fix: Show sidebar for selected revision with list of pods/deployments Result: Knative revision sidebar has list of pods/deployments
Clone Of:
Environment:
Last Closed: 2020-05-04 11:34:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
Number of pods (210.28 KB, image/png)
2020-03-03 11:12 UTC, Gajanan More
no flags Details
Display of information (196.11 KB, image/png)
2020-03-03 11:13 UTC, Gajanan More
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4246 None closed Bug 1800559: adds pod list and deployment in revision sidebar 2020-04-20 11:33:31 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:35:11 UTC

Description Jaivardhan Kumar 2020-02-07 12:26:59 UTC
Description of problem:
Knative revision sidebar doesn't show associated deployment or pods


How reproducible: Always


Steps to Reproduce:
1. Install OpenShift Serverless operator
2. Create a knative service with DevConsole Add flow
3. Go topology view 
3. Once Revisions are created, click on Revision
4. check the sidebar for revision

Actual results:
Knative revision sidebar doesn't show associated deployment or pods

Expected results:
Knative revision sidebar should show associated deployment or pods

Comment 2 Gajanan More 2020-03-03 11:12:48 UTC
Created attachment 1667160 [details]
Number of pods

Comment 3 Gajanan More 2020-03-03 11:13:50 UTC
Created attachment 1667161 [details]
Display of information

Comment 4 Gajanan More 2020-03-03 11:15:42 UTC
I have validated this on 
Build: 4.4.0-0.ci-2020-03-03-033811
Browser: Google Chrome Version 78.0.3904.108
Marking this bug as verified

Comment 6 errata-xmlrpc 2020-05-04 11:34:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.