Bug 180059 - segfault on startup
segfault on startup
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: sound-juicer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-05 03:38 EST by Dave Jones
Modified: 2015-01-04 17:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-10 17:54:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2006-02-05 03:38:07 EST
I popped in a cd, and fired up sound-juicer. it died.
Subsequent attempts to repeat it have failed, but here's the traceback from the
coredump.

#0  update_ui_for_album (album=Variable "album" is not available.
) at sj-main.c:367
367           TrackDetails *track = (TrackDetails*)l->data;
(gdb) bt
#0  update_ui_for_album (album=Variable "album" is not available.
) at sj-main.c:367
#1  0x000000000040ed36 in metadata_cb (m=Variable "m" is not available.
) at sj-main.c:611
#2  0x0000003e4ee0ae68 in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#3  0x0000003e4ee1a56a in g_signal_override_class_closure () from
/usr/lib64/libgobject-2.0.so.0
#4  0x0000003e4ee1b765 in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#5  0x0000003e4ee1ca90 in g_signal_emit_by_name () from
/usr/lib64/libgobject-2.0.so.0
#6  0x0000000000413131 in fire_signal_idle (m=Variable "m" is not available.
) at sj-metadata-musicbrainz.c:247
#7  0x0000003e4ea24e91 in g_main_context_dispatch () from
/usr/lib64/libglib-2.0.so.0
#8  0x0000003e4ea27cad in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#9  0x0000003e4ea27ffe in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#10 0x0000003e50d0bf45 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#11 0x000000000040fcd6 in main (argc=1, argv=0x7fffffc35a78) at sj-main.c:1425
Comment 1 Christopher Aillon 2006-02-07 11:30:50 EST
I think this was just bad dependencies... is this fixed in rawhide?
Comment 2 Dave Jones 2006-02-09 21:55:33 EST
dunno. I couldn't reproduce it more than once even with the same version I first
saw the problem with.
Comment 3 Christopher Aillon 2006-02-10 17:54:16 EST
meh.  i can't reproduce either. ->worksforme.  if you see it again, reopen it,
but it could just be that sound-juicer hates you.  ;-)

Note You need to log in before you can comment on or make changes to this bug.