Bug 1800696 - Unpinned CI dependency in template-service-broker-operator dropped support for Python 2
Summary: Unpinned CI dependency in template-service-broker-operator dropped support fo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.z
Assignee: Fabian von Feilitzsch
QA Contact: Cuiping HUO
URL:
Whiteboard:
Depends On: 1797849
Blocks: 1800707
TreeView+ depends on / blocked
 
Reported: 2020-02-07 17:48 UTC by Fabian von Feilitzsch
Modified: 2020-05-12 14:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1800707 1800710 1800711 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:34:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift template-service-broker-operator pull 69 0 None closed Bug 1800696: pin CI dependencies 2020-05-27 09:46:57 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:35:16 UTC

Description Fabian von Feilitzsch 2020-02-07 17:48:56 UTC
Description of problem:
more-itertools, pulled in by setuptools, dropped support for python2. We need to pin the more-itertools version to 

Version-Release number of selected component (if applicable):
First showed up in 4.4, likely needs to be backported to all versions

How reproducible:
100%

Steps to Reproduce:
1. Attempt to build the CI dockerfile with the command `docker build -f build/custom-ci-build-root.Dockerfile .

Actual results:
Syntax error during install due to `yield from` syntax in more-itertools dependency

Expected results:
Build succeeds

Additional info:

Comment 2 Cuiping HUO 2020-02-10 02:59:27 UTC
depends on 1797849,app registry redhat-operators-art doesn't have 4.4 packagemanifest for tsb testing

Comment 3 Cuiping HUO 2020-02-28 08:44:09 UTC
Verified. Both template-service-broker-operator and template-service-broker can be installed successfully with the image 4.4.0-202002270901

Cluster version: 4.4.0-0.nightly-2020-02-25-122356

$ oc get csv -n openshift-template-service-broker
NAME                                                        DISPLAY                                      VERSION              REPLACES   PHASE
openshifttemplateservicebrokeroperator.4.4.0-202002270901   OpenShift Template Service Broker Operator   4.4.0-202002270901              Succeeded

$ oc get po -n openshift-template-service-broker
NAME                                                         READY   STATUS      RESTARTS   AGE
apiserver-2-deploy                                           0/1     Completed   0          3m6s
apiserver-2-gtlbs                                            1/1     Running     0          3m1s
openshift-template-service-broker-operator-75b5b486d-xjdsh   1/1     Running     0          17m


$ oc logs -f openshift-template-service-broker-operator-75b5b486d-xjdsh 
{"level":"info","ts":1582877502.575054,"logger":"cmd","msg":"Go Version: go1.13.4"}
{"level":"info","ts":1582877502.575086,"logger":"cmd","msg":"Go OS/Arch: linux/amd64"}
{"level":"info","ts":1582877502.57509,"logger":"cmd","msg":"Version of operator-sdk: v0.12.0+git"}
{"level":"info","ts":1582877502.5751038,"logger":"cmd","msg":"Watching namespace.","Namespace":"openshift-template-service-broker"}
{"level":"info","ts":1582877504.881091,"logger":"controller-runtime.metrics","msg":"metrics server is starting to listen","addr":"0.0.0.0:8383"}
{"level":"info","ts":1582877504.882064,"logger":"watches","msg":"Failed to parse %v from environment. Using default %v","WORKER_TEMPLATESERVICEBROKER_OSB_OPENSHIFT_IO":1}
{"level":"info","ts":1582877504.8820877,"logger":"watches","msg":"Failed to parse %v from environment. Using default %v","ANSIBLE_VERBOSITY_TEMPLATESERVICEBROKER_OSB_OPENSHIFT_IO":2}
{"level":"info","ts":1582877504.882132,"logger":"ansible-controller","msg":"Watching resource","Options.Group":"osb.openshift.io","Options.Version":"v1","Options.Kind":"TemplateServiceBroker"}
{"level":"info","ts":1582877504.8823855,"logger":"controller-runtime.controller","msg":"Starting EventSource","controller":"templateservicebroker-controller","source":"kind source: osb.openshift.io/v1, Kind=TemplateServiceBroker"}
{"level":"info","ts":1582877504.8825443,"logger":"leader","msg":"Trying to become the leader."}
{"level":"info","ts":1582877507.1978598,"logger":"leader","msg":"No pre-existing lock was found."}
{"level":"info","ts":1582877507.2054505,"logger":"leader","msg":"Became the leader."}
{"level":"info","ts":1582877511.9299388,"logger":"metrics","msg":"Metrics Service object created","Service.Name":"openshift-template-service-broker-operator-metrics","Service.Namespace":"openshift-template-service-broker"}
{"level":"info","ts":1582877511.931552,"logger":"proxy","msg":"Starting to serve","Address":"127.0.0.1:8888"}
{"level":"info","ts":1582877511.931719,"logger":"controller-runtime.manager","msg":"starting metrics server","path":"/metrics"}
{"level":"info","ts":1582877512.031874,"logger":"controller-runtime.controller","msg":"Starting Controller","controller":"templateservicebroker-controller"}
{"level":"info","ts":1582877512.1320791,"logger":"controller-runtime.controller","msg":"Starting workers","controller":"templateservicebroker-controller","worker count":1}
{"level":"info","ts":1582877625.7347991,"logger":"logging_event_handler","msg":"[playbook task]","name":"template-service-broker","namespace":"openshift-template-service-broker","gvk":"osb.openshift.io/v1, Kind=TemplateServiceBroker","event_type":"playbook_on_task_start","job":"4037200794235010051","EventData.Name":"Validation"}
{"level":"info","ts":1582877625.7831213,"logger":"logging_event_handler","msg":"[playbook task]","name":"template-service-broker","namespace":"openshift-template-service-broker","gvk":"osb.openshift.io/v1, Kind=TemplateServiceBroker","event_type":"playbook_on_task_start","job":"4037200794235010051","EventData.Name":"Run template-service-broker role"}
{"level":"info","ts":1582877626.195513,"logger":"logging_event_handler","msg":"[playbook task]","name":"template-service-broker","namespace":"openshift-template-service-broker","gvk":"osb.openshift.io/v1, Kind=TemplateServiceBroker","event_type":"playbook_on_task_start","job":"4037200794235010051","EventData.Name":"template-service-broker : Set tsb objects state=present"}
{"level":"info","ts":1582877629.42366,"logger":"proxy","msg":"Cache miss: /v1, Kind=ServiceAccount, openshift-template-service-broker/apiserver"}
{"level":"info","ts":1582877629.4294393,"logger":"proxy","msg":"Injecting owner reference"}
{"level":"info","ts":1582877629.4297712,"logger":"proxy","msg":"Watching child resource","kind":"/v1, Kind=ServiceAccount","enqueue_kind":"osb.openshift.io/v1, Kind=TemplateServiceBroker"}
{"level":"info","ts":1582877629.4298913,"logger":"controller-runtime.controller","msg":"Starting EventSource","controller":"templateservicebroker-controller","source":"kind source: /v1, Kind=ServiceAccount"}
{"level":"info","ts":1582877630.090335,"logger":"proxy","msg":"Injecting owner reference"}
{"level":"info","ts":1582877630.7633152,"logger":"proxy","msg":"Injecting owner reference"}
{"level":"info","ts":1582877632.5115201,"logger":"proxy","msg":"Cache miss: apps.openshift.io/v1, Kind=DeploymentConfig, openshift-template-service-broker/apiserver"}
{"level":"info","ts":1582877632.5241218,"logger":"proxy","msg":"Injecting owner reference"}
{"level":"info","ts":1582877632.524483,"logger":"proxy","msg":"Watching child resource","kind":"apps.openshift.io/v1, Kind=DeploymentConfig","enqueue_kind":"osb.openshift.io/v1, Kind=TemplateServiceBroker"}
{"level":"info","ts":1582877632.5245101,"logger":"controller-runtime.controller","msg":"Starting EventSource","controller":"templateservicebroker-controller","source":"kind source: apps.openshift.io/v1, Kind=DeploymentConfig"}
{"level":"info","ts":1582877633.2936316,"logger":"proxy","msg":"Cache miss: /v1, Kind=ConfigMap, openshift-template-service-broker/apiserver-config"}
{"level":"info","ts":1582877633.2997205,"logger":"proxy","msg":"Injecting owner reference"}
{"level":"info","ts":1582877633.300024,"logger":"proxy","msg":"Watching child resource","kind":"/v1, Kind=ConfigMap","enqueue_kind":"osb.openshift.io/v1, Kind=TemplateServiceBroker"}
{"level":"info","ts":1582877633.3000572,"logger":"controller-runtime.controller","msg":"Starting EventSource","controller":"templateservicebroker-controller","source":"kind source: /v1, Kind=ConfigMap"}
{"level":"info","ts":1582877634.0597928,"logger":"proxy","msg":"Cache miss: /v1, Kind=Service, openshift-template-service-broker/apiserver"}
{"level":"info","ts":1582877634.0740337,"logger":"proxy","msg":"Injecting owner reference"}
{"level":"info","ts":1582877634.0743365,"logger":"proxy","msg":"Watching child resource","kind":"/v1, Kind=Service","enqueue_kind":"osb.openshift.io/v1, Kind=TemplateServiceBroker"}
{"level":"info","ts":1582877634.0743587,"logger":"controller-runtime.controller","msg":"Starting EventSource","controller":"templateservicebroker-controller","source":"kind source: /v1, Kind=Service"}
{"level":"info","ts":1582877634.8406346,"logger":"proxy","msg":"Cache miss: /v1, Kind=ConfigMap, openshift-template-service-broker/apiserver-service-ca-bundle"}
{"level":"info","ts":1582877634.8473241,"logger":"proxy","msg":"Injecting owner reference"}
{"level":"info","ts":1582877635.5219548,"logger":"proxy","msg":"Cache miss: /v1, Kind=ServiceAccount, openshift-template-service-broker/template-service-broker-client"}
{"level":"info","ts":1582877635.5883653,"logger":"proxy","msg":"Injecting owner reference"}
{"level":"info","ts":1582877636.3230052,"logger":"proxy","msg":"Injecting owner reference"}
{"level":"info","ts":1582877637.0859134,"logger":"proxy","msg":"Injecting owner reference"}
{"level":"info","ts":1582877637.8535345,"logger":"proxy","msg":"Cache miss: /v1, Kind=Secret, openshift-template-service-broker/template-service-broker-client"}
{"level":"info","ts":1582877637.8588345,"logger":"proxy","msg":"Injecting owner reference"}

$ oc logs -f apiserver-2-gtlbs 
I0228 08:26:18.009520       1 secure_serving.go:116] Serving securely on [::]:8443
I0228 08:26:18.010964       1 controller_utils.go:1027] Waiting for caches to sync for tsb controller
I0228 08:26:18.711236       1 controller_utils.go:1034] Caches are synced for tsb controller

Comment 5 errata-xmlrpc 2020-05-04 11:34:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.