Bug 1800698 - JSON error trying to install Helm Chart
Summary: JSON error trying to install Helm Chart
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: cvogt
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-07 17:52 UTC by Samuel Padgett
Modified: 2020-05-04 11:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.4.0-0.ci-2020-02-06-162333 Cluster ID: 4dd4683b-9318-45e7-97dd-f7b5f8debf00 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:72.0) Gecko/20100101 Firefox/72.0
Last Closed: 2020-05-04 11:34:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4175 None closed Bug 1800698: Fixed Helm chart installation 2020-04-21 22:15:39 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:35:16 UTC

Description Samuel Padgett 2020-02-07 17:52:14 UTC
Description of problem:

There appear to be two problems here:

1. The chart failed to install with this error

{"error":"Failed to install helm chart: mkdir /.cache: permission denied"}null

2. The "null" at the end of the HTTP response caused a JSON parse error, masking the server error message

JSON.parse: unexpected non-whitespace character after JSON data at line 1 column 75 of the JSON data

How reproducible:
Always

Steps to Reproduce:
1. Go to Developer perspective
2. Click Add
3. Select project if necessary
4. Select From Catalog
5. Filter for the Helm Chart
6. Select the chart and click Install
7. Enter a name
8. Click Install

Actual results:

JSON parse error

Expected results:

The chart is installed

Comment 3 Ruchir Garg 2020-03-02 06:38:35 UTC
Bulk assigning all to Gajanan for verification.

Comment 4 Gajanan More 2020-03-02 09:13:25 UTC
https://issues.redhat.com/browse/ODC-2876 verified by Gajanan More

Comment 6 errata-xmlrpc 2020-05-04 11:34:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.