Bug 1800769 - Cluster Overview: prop type warning hovering over utilization chart
Summary: Cluster Overview: prop type warning hovering over utilization chart
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: Rastislav Wagner
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-07 20:50 UTC by Samuel Padgett
Modified: 2020-07-13 17:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: missing property for react component Consequence: an error message may appear in browser's console Fix: add missing property for react component Result: error message wont occur anymore
Clone Of:
Environment:
Version: 4.4.0-0.ci-2020-02-07-125353 Cluster ID: 02913ce8-f389-409b-a79d-8d6ecdf40695 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:72.0) Gecko/20100101 Firefox/72.0
Last Closed: 2020-07-13 17:14:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5376 None open Bug 1800769: Define pointerLength prop for multiline charts 2020-06-23 08:25:58 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:14:49 UTC

Description Samuel Padgett 2020-02-07 20:50:31 UTC
I saw this prop type warning hovering over a utilization chart on the home -> overview page. I don't have exact steps to reproduce, and it didn't seem to have any bad effects. We should investigate, though.

Warning: Failed prop type: The prop `center.x` is marked as required in `ChartTooltip`, but its value is `undefined`.
    in ChartTooltip (created by AreaChart)
    in VictoryVoronoiContainer (created by ChartVoronoiContainer)
    in ChartVoronoiContainer (created by AreaChart)
    in VictorySharedEvents (created by VictoryChart)
    in VictoryChart (created by Chart)
    in Chart (created by AreaChart)
    in a (created by Context.Consumer)
    in Link (created by PrometheusGraphLink_)
    in PrometheusGraphLink_ (created by ConnectFunction)
    in ConnectFunction (created by AreaChart)
    in div (created by ForwardRef)
    in ForwardRef (created by AreaChart)
    in AreaChart
    in div
    in div
    in Unknown
    in Unknown (created by WithDashboardResources)
    in Unknown
    in Unknown (created by ConnectFunction)
    in ConnectFunction (created by Firehose)
    in Firehose (created by ConnectFunction)
    in ConnectFunction (created by WithDashboardResources)
    in WithDashboardResources (created by ConnectFunction)
    in ConnectFunction
    in div (created by Grid)
    in Grid (created by UtilizationBody)
    in div (created by UtilizationBody)
    in UtilizationBody
    in article (created by Card)
    in Card
    in Unknown
    in Unknown (created by ConnectFunction)
    in ConnectFunction (created by DashboardGrid)
    in div (created by GridItem)
    in GridItem (created by DashboardGrid)
    in div (created by Grid)
    in Grid (created by DashboardGrid)
    in div (created by GridItem)
    in GridItem (created by DashboardGrid)
    in div (created by Grid)
    in Grid (created by DashboardGrid)
    in div (created by DashboardGrid)
    in DashboardGrid (created by ClusterDashboard)
    in div (created by Dashboard)
    in Dashboard (created by ClusterDashboard)
    in ClusterDashboard (created by Context.Consumer)

Comment 3 Yadan Pei 2020-05-12 06:11:54 UTC
hovering over a utilization chart on the home -> overview page, didn't see this warning message. Since it looks not reproducible every time, I will move to VERIFIED 

Verified on 4.5.0-0.nightly-2020-05-11-202959

Comment 5 errata-xmlrpc 2020-07-13 17:14:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.