Bug 1801028 - Number should be Int on integrated Grafana dashboard for etcd cluster
Summary: Number should be Int on integrated Grafana dashboard for etcd cluster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-10 03:39 UTC by XiaochuanWang
Modified: 2020-05-13 21:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:57:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
number of etcd cluster (274.41 KB, image/png)
2020-02-10 03:39 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4271 None closed Bug 1801028: Improve dashboard single-stat number formatting 2020-04-17 17:55:40 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:57:13 UTC

Description XiaochuanWang 2020-02-10 03:39:28 UTC
Created attachment 1662034 [details]
number of etcd cluster

Description of problem:
Cluster admin check the integrated Grafana dashboard on the "Monitoring -> Dashboard" page, the etcd is 3.00. 

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-09-193413

How reproducible:
Always

Steps to Reproduce:
1. cluster-admin go to "Monitoring -> Dashboard" page and check the etcd cluster number.

Actual results:
The number is 3.00 (refer to the screenshot)

Expected results:
According to the design of integrated Grafana dashboard: https://docs.google.com/document/d/1yk-Ef_YGRJUiuVNFwxcar_qeFDveKYLyILAnbDDfTb0/edit#heading=h.mqgbeivyjj0u
The number should be Int.


Additional info:
Layout should better be adjusted.

Comment 1 Samuel Padgett 2020-02-10 14:04:20 UTC
We should share the `formatNumber` utility between the table component and single stat component:

https://github.com/openshift/console/blob/master/frontend/public/components/monitoring/dashboards/table.tsx#L28-L51

Comment 3 Yanping Zhang 2020-02-14 08:50:59 UTC
Checked on ocp 4.4 with payload 4.4.0-0.nightly-2020-02-13-212616, goto "Monitoring -> Dashboard" page, the number for etcd cluster is integer "3".
The bug is fixed, so move it to Verified.

Comment 5 errata-xmlrpc 2020-05-13 21:57:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.