Bug 180112 - RFE: Add vmmouse driver package to FC5
RFE: Add vmmouse driver package to FC5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drivers (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-02-05 17:57 EST by Mike A. Harris
Modified: 2013-01-09 22:41 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-08 16:46:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2006-02-05 17:57:45 EST
Since the release of X11R7.0, a new input driver "vmmouse" was added to
the upstream repository, and a release made.  This is a mouse driver for
use under VMware, which should be added to FC5 for completeness.

I've created an initial package based from the "xorg-x11-drv-mouse" package,
and imported it into CVS.

Here is what remains to be done:

1) It needs to be added to beehive.

2) Build it in dist-fc5

3) Add it as a driver to xorg-x11-drivers, for the 3 arches it builds for.

4) Notify jeremy in case our config tools need to be updated to autodetect
   VMware's USB IDs or whatever, and automatically configure X to use vmmouse
   under VMware installations.  (Not sure if that's the case or not, but if
   it is, it would be convenient to VMware users I suppose.)


CC'ing katzj and notting
Comment 1 Bill Nottingham 2006-02-06 11:00:53 EST
Why does vmware need a separate mouse driver????
Comment 2 Mike A. Harris 2006-02-08 12:34:53 EST
(In reply to comment #1)
> Why does vmware need a separate mouse driver????

I'm told that it is to avoid synchronization problems due to host mouse
acceleration plus guest OS mouse acceleration, and that it makes it easy
to implement smart mouse grabbing.  ie:  When the edge of the screen is
reached in the guest OS, the mouse can be released, and it will seemlessly
move away in the right spot on the host.

Similar things are done inside qemu for example.  Anyway, VMware Inc. has
requested this be added to the OS, and it is a standard Xorg driver now,
so there's no good reason for us to not add it.  If we don't add it now,
we'll get a RHEL request later to add it, and we'll be adding a driver to
RHEL which had no Fedora testing.



Comment 3 Mike A. Harris 2006-02-08 12:48:35 EST
As per:
https://intranet.corp.redhat.com/ic/intranet/PackageListProcess.html

notting: Can you rubber stamp this, so it can get into test3 ASAP?


jeremy:  Does this require any installer, etc. changes?  I believe it is
desireable if the vmmouse driver gets assigned for all VMware installations.

I'm not sure how to detect that currently though, however that is something
that could be done at a later date, as it works without it still.


jkeating: Can you add 'xorg-x11-drv-vmmouse' to beehive, etc.


TIA guys...
Comment 4 Jeremy Katz 2006-02-08 13:16:17 EST
Yes, there will be real installer changes needed if we want to associate the
different mouse driver if you're on VMware.  And that's going to require some
digging to figure out how you can tell that you need to, etc.  I don't know that
this is really viable for FC5.  Test2 (the nominal feature freeze) was a month ago.
Comment 5 Mike A. Harris 2006-02-08 13:34:19 EST
(In reply to comment #4)
> Yes, there will be real installer changes needed if we want to associate the
> different mouse driver if you're on VMware.  And that's going to require some
> digging to figure out how you can tell that you need to, etc.

I assumed that might be necessary, however the driver is still useful
being in the OS, even if it isn't configured by default.

> I don't know that this is really viable for FC5.  Test2 (the nominal
> feature freeze) was a month ago.

I realize that.  A month ago the driver didn't exist to make a package
for.

Anyway, including it is pretty much 0 risk to us, and gets some end user
testing, even if it has to be manually configured.  I believe VMware's
installation might even configure it itself if it's present, but I'm
not sure.

I don't see any reason to not include it really, but I also don't feel
strongly to fight for its inclusion if there is strong opposition either.

If we had monolithic X, I'd have just put the driver source into the
monolith and rebuilt it, and nobody would know/care or have needed to
approved it really.  Currently I'm just wasting cycles caught up in
needless "process" for a low risk driver that doesn't harm anything.

Please either approve it, or move this bug to FC6Target so I can get
immediate closure.

Thanks in advance.
Comment 6 Mike A. Harris 2006-02-08 16:42:16 EST
Package approvals for FC5:

Tech lead (notting):  refused
    Why does vmware need a separate mouse driver???? (comment #1)

Installer (jeremy):  refused
    Probably requires installer changes to fully integrate.  It is
    past the FC5 package inclusion deadline.

RELENG (jkeating):  refused
    Didn't get necessary prerequisite approvals.



Comment 7 Mike A. Harris 2006-02-08 16:44:45 EST
Defering driver inclusion until FC6.
Comment 8 Mike A. Harris 2006-07-21 17:33:36 EDT
Already included for a while now....

Note You need to log in before you can comment on or make changes to this bug.