Bug 1801292 - oc rsh doesn't take a -f
Summary: oc rsh doesn't take a -f
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
: 1707833 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-10 15:04 UTC by David Eads
Modified: 2020-07-13 17:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:14:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oc pull 397 0 None closed Bug 1801292: support -f for rsh command 2020-06-23 08:26:22 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:15:25 UTC

Description David Eads 2020-02-10 15:04:44 UTC
[deads@deads-02 cluster-etcd-operator]$ oc rsh -f ~/Downloads/debug-pod.yaml 
Error: unknown shorthand flag: 'f' in -f


this prevents creating a pod manifest and rsh into it immediately.  the kubectl standard is to take a -f and harvest the namespace and name from it.

Comment 1 Maciej Szulik 2020-02-24 13:38:13 UTC
The upstream part is in https://github.com/kubernetes/kubernetes/pull/88460
we'll get it in the next release.

Comment 2 Maciej Szulik 2020-02-26 19:38:17 UTC
*** Bug 1707833 has been marked as a duplicate of this bug. ***

Comment 3 Maciej Szulik 2020-05-20 08:27:33 UTC
PRs in the queue.

Comment 6 zhou ying 2020-05-27 03:27:32 UTC
[zhouying@dhcp-140-138 ~]$ oc version 
Client Version: 4.5.0-202005270117-384535d
Kubernetes Version: v1.18.2+9835af5


[zhouying@dhcp-140-138 ~]$ oc rsh -f /tmp/hellopod.yaml  cat /etc/resolv.conf
search zhouyrsh.svc.cluster.local svc.cluster.local cluster.local c.openshift-qe.internal google.internal
nameserver 172.30.0.10
options ndots:5

Comment 8 errata-xmlrpc 2020-07-13 17:14:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.