Bug 1801294 - [marketplace] Alert to make custom operatorsource users aware of deprecation
Summary: [marketplace] Alert to make custom operatorsource users aware of deprecation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Anik
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks: 1808591
TreeView+ depends on / blocked
 
Reported: 2020-02-10 15:05 UTC by Kevin Rizza
Modified: 2020-07-13 17:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1808591 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:14:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-marketplace pull 282 0 None closed Bug 1801294: Alert to make custom opsrc/csc users aware of deprecation 2020-11-19 16:40:53 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:15:25 UTC

Description Kevin Rizza 2020-02-10 15:05:51 UTC
Description of problem:
In 4.5 we are deprecating the OperatorSource and CatalogSourceConfig APIs. For default OperatorSources, this is fine because we will migrate any existing OLM workloads onto new CatalogSources that are index image based.

However, for non default custom OperatorSources and for all CatalogSourceConfigs we will need to alert users that these resources will need to be migrated manually after they are deprecated.

Version-Release number of selected component (if applicable):


How reproducible:

Always.


Steps to Reproduce:
1. Create a custom OperatorSource or CatalogSourceConfig

Actual results:

No alert is created.

Expected results:

See an alert created that lets an administrator know these APIs are being deprecated.

Comment 3 Fan Jia 2020-03-09 03:23:38 UTC
test env:
cv: 4.5.0-0.nightly-2020-03-06-190457

test result:
1. create opsrc& csc in cluster.

the logs of marketplace-operator:
$ oc logs marketplace-operator-5cfdc9cb4-lm28c | grep "DEPRECATION NOTICE"
time="2020-03-09T03:16:34Z" level=warning msg="DEPRECATION NOTICE: The OperatorSource API is deprecated in future versions. Please visit this link for futher details: https://docs.openshift.com/container-platform/4.4/release_notes/ocp-4-4-release-notes.html#ocp-4-4-marketplace-apis-deprecated"
time="2020-03-09T03:16:34Z" level=warning msg="DEPRECATION NOTICE: The OperatorSource API is deprecated in future versions. Please visit this link for futher details: https://docs.openshift.com/container-platform/4.4/release_notes/ocp-4-4-release-notes.html#ocp-4-4-marketplace-apis-deprecated"
time="2020-03-09T03:16:34Z" level=warning msg="DEPRECATION NOTICE: The OperatorSource API is deprecated in future versions. Please visit this link for futher details: https://docs.openshift.com/container-platform/4.4/release_notes/ocp-4-4-release-notes.html#ocp-4-4-marketplace-apis-deprecated"
time="2020-03-09T03:16:35Z" level=warning msg="DEPRECATION NOTICE: The OperatorSource API is deprecated in future versions. Please visit this link for futher details: https://docs.openshift.com/container-platform/4.4/release_notes/ocp-4-4-release-notes.html#ocp-4-4-marketplace-apis-deprecated"
time="2020-03-09T03:21:31Z" level=warning msg="DEPRECATION NOTICE: The CatalogSourceConfig API is deprecated in future versions. Please visit this link for futher details: https://docs.openshift.com/container-platform/4.4/release_notes/ocp-4-4-release-notes.html#ocp-4-4-marketplace-apis-deprecated"
time="2020-03-09T03:21:31Z" level=warning msg="DEPRECATION NOTICE: The CatalogSourceConfig API is deprecated in future versions. Please visit this link for futher details: https://docs.openshift.com/container-platform/4.4/release_notes/ocp-4-4-release-notes.html#ocp-4-4-marketplace-apis-deprecated"
time="2020-03-09T03:21:31Z" level=warning msg="DEPRECATION NOTICE: The CatalogSourceConfig API is deprecated in future versions. Please visit this link for futher details: https://docs.openshift.com/container-platform/4.4/release_notes/ocp-4-4-release-notes.html#ocp-4-4-marketplace-apis-deprecated"
time="2020-03-09T03:21:31Z" level=warning msg="DEPRECATION NOTICE: The CatalogSourceConfig API is deprecated in future versions. Please visit this link for futher details: https://docs.openshift.com/container-platform/4.4/release_notes/ocp-4-4-release-notes.html#ocp-4-4-marketplace-apis-deprecated"
time="2020-03-09T03:21:31Z" level=warning msg="DEPRECATION NOTICE: The CatalogSourceConfig API is deprecated in future versions. Please visit this link for futher details: https://docs.openshift.com/container-platform/4.4/release_notes/ocp-4-4-release-notes.html#ocp-4-4-marketplace-apis-deprecated"
time="2020-03-09T03:21:31Z" level=warning msg="DEPRECATION NOTICE: The CatalogSourceConfig API is deprecated in future versions. Please visit this link for futher details: https://docs.openshift.com/container-platform/4.4/release_notes/ocp-4-4-release-notes.html#ocp-4-4-marketplace-apis-deprecated"


the status of upgradeable of marketplace :
  - lastTransitionTime: "2020-03-09T03:17:05Z"
    message: 'The cluster has custom OperatorSource/CatalogSourceConfig, which are
      deprecated in future versions. Please visit this link for further deatils: https://docs.openshift.com/container-platform/4.4/release_notes/ocp-4-4-release-notes.html#ocp-4-4-marketplace-apis-deprecated'
    reason: DprecatedAPIsInUse
    status: "False"
    type: Upgradeable

Comment 5 errata-xmlrpc 2020-07-13 17:14:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.