Bug 1801295 - The pod donut is showing two phrases when scaling up from 0
Summary: The pod donut is showing two phrases when scaling up from 0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Aritra Roy
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-10 15:07 UTC by Aritra Roy
Modified: 2020-05-13 21:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:57:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
pod_text for deployment scaling up from zero (11.23 KB, image/png)
2020-02-10 15:07 UTC, Aritra Roy
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4090 None closed Bug 1801295: fix pod ring text while scaling up from 0 2020-04-20 09:21:07 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:57:31 UTC

Description Aritra Roy 2020-02-10 15:07:50 UTC
Created attachment 1662164 [details]
pod_text for deployment scaling up from zero

Description of problem:
The pod donut is showing two phrases when scaling up from 0. It should show the # of pods plus the "scaling up phrase".

Version-Release number of selected component (if applicable):
4.4.0-0.ci-2020-02-09-194845

Steps to Reproduce:
1.Create a Deployment or DeploymentConfig from one of the import flows
2.check the Pod Count filter in topology

Actual results:
Pod text shows scaled to 0 and scaling to 1 during first scale up or any scale up from 0

Expected results:
At resting state, a pod should should show either of these:

    Autoscaled to 0
    Scaled to 0
    # of pods
When it's scaling up or down, it should say:
    Scaling to # (desired number of pods)

Comment 3 Ruchir Garg 2020-03-02 06:38:43 UTC
Bulk assigning all to Gajanan for verification.

Comment 4 Gajanan More 2020-03-03 09:14:08 UTC
Gajanan More has validated the bug (ODC-2566) on
Build: 4.4.0-0.ci-2020-03-03-033811
Browser: Google Chrome Version 78.0.3904.108

Comment 6 errata-xmlrpc 2020-05-13 21:57:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.