Bug 1801344 - cluster-etcd-operator: builds are failing required with minimal version "1.13.5", detected version "1.13.4".
Summary: cluster-etcd-operator: builds are failing required with minimal version "1.13...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-10 17:01 UTC by Sam Batschelet
Modified: 2020-05-13 21:57 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:57:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 109 0 None closed Bug 1801344: vendor: bump build-machinery-go 2020-09-30 11:24:34 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:57:37 UTC

Description Sam Batschelet 2020-02-10 17:01:08 UTC
Description of problem:

Builds are failing

>vendor/github.com/openshift/build-machinery-go/make/targets/golang/../../lib/golang.mk:22: *** `go` is required with minimal version "1.13.5", detected version "1.13.4". You can override this check by using `make GO_REQUIRED_MIN_VERSION:=`.  Stop.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results: build failure


Expected results: build success


Additional info: resolved by bumping dep[1]

[1] 
https://github.com/openshift/cluster-etcd-operator/pull/109/files#diff-17442a53a3318d07cc4c974c17dce448R20

Comment 2 ge liu 2020-03-09 08:01:03 UTC
it should be fixed in build level

Comment 4 errata-xmlrpc 2020-05-13 21:57:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.