Bug 1801419 - When create connector via drag operation fails, no indication is given to the user
Summary: When create connector via drag operation fails, no indication is given to the...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-10 20:26 UTC by Jeff Phillips
Modified: 2020-05-04 11:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.4.0-0.ci-2020-02-09-194845 Cluster ID: ab36f720-0913-4c27-ad04-8bd7c12537f3 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.130 Safari/537.36
Last Closed: 2020-05-04 11:35:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4274 None closed Bug 1801419: Show an error dialog when creation of a connection fails 2020-04-28 20:21:40 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:35:55 UTC

Description Jeff Phillips 2020-02-10 20:26:47 UTC
Description of problem:

If, for some valid reason, the creation of a connector fails when dragging the `create connector` in topology, there is no message given to the user indicating the failure


Version-Release number of selected component (if applicable):


How reproducible:

Rarely

Steps to Reproduce:
1. From the Developer perspective, navigate to Topology
2. Drag the create connector handle from one node to another that causes a failure

Actual results:

No connection is created, no indication of why is given

Expected results:

No connection is created, the user is informed as to the reason for the failure

Additional info:

Comment 3 Gajanan More 2020-03-02 11:29:15 UTC
https://issues.redhat.com/browse/ODC-2962 verified by Andrew

Comment 5 errata-xmlrpc 2020-05-04 11:35:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.