Bug 1801430 - oc rsh -n openshift-etcd etcd-member-pod should have working etcdctl
Summary: oc rsh -n openshift-etcd etcd-member-pod should have working etcdctl
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.3.z
Assignee: Suresh Kolichala
QA Contact: ge liu
URL:
Whiteboard:
Depends On: 1795696
Blocks: 1834823
TreeView+ depends on / blocked
 
Reported: 2020-02-10 21:00 UTC by Suresh Kolichala
Modified: 2020-05-27 17:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Provide environment variables for straightforward execution of etcdctl commands on pods. Reason: Currently the user has to set several env variables involving TLS certs and ETCDCTL API version to be able to successfully run etcdctl command. Result: With this feature, the environment variables needed for straightforward execution of etcdctl are written into /root/.profile. So, when the user performs oc rsh, the etcdctl commands should work right-off the bat!
Clone Of: 1795696
Environment:
Last Closed: 2020-05-27 17:00:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1726 None closed [release-4.3] Bug 1801430: Write environment variables needed for etcdctl execution into ~/.profile 2020-06-23 00:59:39 UTC
Red Hat Product Errata RHBA-2020:2184 None None None 2020-05-27 17:01:19 UTC

Comment 1 ge liu 2020-02-12 15:33:40 UTC
"etcdctl member list" should work on etcd pods without any env setting manually in 4.3

Comment 2 Michal Fojtik 2020-05-12 10:33:30 UTC
This bug hasn't had any activity in the last 30 days. Maybe the problem got resolved, was a duplicate of something else, or became less pressing for some reason - or maybe it's still relevant but just hasn't been looked at yet.

As such, we're marking this bug as "LifecycleStale" and decreasing severity from "medium" to "low".

If you have further information on the current state of the bug, please update it, otherwise this bug will be automatically closed in 7 days. The information can be, for example, that the problem still occurs, that you still want the feature, that more information is needed, or that the bug is (for whatever reason) no longer relevant.

Comment 6 ge liu 2020-05-18 03:40:44 UTC
Verified with 4.3.21

# oc rsh etcd-member-control-plane-0
Defaulting container name to etcd-member.
Use 'oc describe pod/etcd-member-control-plane-0 -n openshift-etcd' to see all of the containers in this pod.
sh-4.2# etcdctl
NAME:
	etcdctl - A simple command line client for etcd3.

Comment 8 errata-xmlrpc 2020-05-27 17:00:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2184


Note You need to log in before you can comment on or make changes to this bug.