Bug 1801447 - Error on the topology page when User tries to connect the node to itself
Summary: Error on the topology page when User tries to connect the node to itself
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-10 21:38 UTC by Jeff Phillips
Modified: 2020-05-04 11:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Version: 4.4.0-0.ci-2020-02-09-194845 Cluster ID: ab36f720-0913-4c27-ad04-8bd7c12537f3 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.130 Safari/537.36
Last Closed: 2020-05-04 11:35:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4276 None closed Bug 1801447: Fix for invalid edges, do not allow connection to knative revisions 2020-03-02 11:52:30 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:35:55 UTC

Description Jeff Phillips 2020-02-10 21:38:31 UTC
Description of problem:

I was trying to check what happens when we try to connect the node to itself. I am facing this problem. I am unable to open the only topology page of the namespace. When I try to create new deployment, then also it is redirecting to black screen.

Version-Release number of selected component (if applicable):


How reproducible:

consistently

Steps to Reproduce:
1. Create new project
2. Create some deployments of knative service type, deployment type
3. Try to connect the knative service node to itself and then try to refresh the page

Actual results:

you will observe that it will redirect to blank screen.

The error from the console:

vendors~main-chunk-8a2b868a91615c9e45f4.min.js:161172 Error: No target node found with ID '5a813c31-3cda-4fae-9ae8-71d28ed4d761'.
    at t.setModel (dev-console-topology-chunk-ea059b00478738a5ce0c.min.js:1)
    at i (dev-console-topology-chunk-ea059b00478738a5ce0c.min.js:1)
    at Array.forEach (<anonymous>)
    at t.fromModel (dev-console-topology-chunk-ea059b00478738a5ce0c.min.js:1)
    at Ot (vendors~dev-console-topology~git-import-form~pipeline-builder-edit-page~pipeline-builder-page~pipeli~b2c8ca75-chunk-faa21a7b6ae540c8bb4b.min.js:84)
    at t.r (vendors~dev-console-topology~git-import-form~pipeline-builder-edit-page~pipeline-builder-page~pipeli~b2c8ca75-chunk-faa21a7b6ae540c8bb4b.min.js:84)
    at dev-console-topology-chunk-ea059b00478738a5ce0c.min.js:1
    at Ma (vendors~main-chunk-8a2b868a91615c9e45f4.min.js:161172)
    at vendors~main-chunk-8a2b868a91615c9e45f4.min.js:161172
    at t.unstable_runWithPriority (vendors~main-chunk-8a2b868a91615c9e45f4.min.js:161466)


Expected results:

Nothing should happen, connecting a node to itself is a no-op. UI refreshes w/o issue.

Additional info:

Comment 3 Gajanan More 2020-03-02 11:53:10 UTC
https://issues.redhat.com/browse/ODC-3014 verified by Aritra Roy

Comment 5 errata-xmlrpc 2020-05-04 11:35:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.