Bug 180157 - Can't authenticate using win2k3 server when sidhistory is set on user
Summary: Can't authenticate using win2k3 server when sidhistory is set on user
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jay Fenlason
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 181409
TreeView+ depends on / blocked
 
Reported: 2006-02-06 13:15 UTC by Bastien Nocera
Modified: 2014-08-31 23:28 UTC (History)
2 users (show)

Fixed In Version: RHBA-2006-0599
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 21:43:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0599 normal SHIPPED_LIVE samba bug fix update 2006-08-10 04:00:00 UTC
Samba Project 2245 None None None Never

Description Bastien Nocera 2006-02-06 13:15:27 UTC
samba-3.0.10-1.4E.2-i386

When running wbinfo -a against such a user:
plaintext password authentication failed
error code was NT code 0x00000001 (0x1)
error messsage was: NT code 0x00000001
Could not authenticate user <stripped> with plaintext password
challenge/response password authentication failed
error code was NT code 0x00000001 (0x1)
error messsage was: NT code 0x00000001
Could not authenticate user <stripped> with challenge/response 

Upstream samba bug at:
https://bugzilla.samba.org/show_bug.cgi?id=2245
And upstream commit message:
http://lists.samba.org/archive/samba-cvs/2005-January/054527.html

Patch tested successfully, and applies with fuzziness against our current samba
version.

Comment 3 Bob Johnson 2006-04-11 15:42:57 UTC
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 4.4 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 4.4 release.

Comment 6 Red Hat Bugzilla 2006-08-10 21:43:08 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0599.html



Note You need to log in before you can comment on or make changes to this bug.