Bug 18016 - Post-install "lilo" installation fails when installing on partition above 8GB limit
Post-install "lilo" installation fails when installing on partition above 8GB...
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-01 06:54 EDT by daniel.deimert
Modified: 2018-02-05 16:54 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-24 16:03:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description daniel.deimert 2000-10-01 06:54:48 EDT
Using the text-mode installer I was able to install using automatic
partitioning a 18GB HD.  The partitions created were well above the 8GB
limit and was closer to the end of the HD.

When post-install executed lilo, a cryptic error message was printed on
screen, and no clear warning was given that the install was going to fail.  

I had a boot disk and booted from this and found that the system had used
the "linear" keyword in /etc/lilo.conf even though you're shipping a lilo
with LBA32 support.  Changing linear to lba32 and rerunning lilo made the
harddisk bootable.
Comment 1 Michael Fulbright 2000-10-02 18:27:26 EDT
What happens to be the geometry and final partition table for the drive in
question (you can attach the
output from 'fdisk -l <device>', where <device> is problem /dev/hda for the
first IDE drive, or /dev/sda for the
first SCSI drive?
Comment 2 daniel.deimert 2000-10-05 15:27:42 EDT
[root@localhost /root]# fdisk -l /dev/hda

Disk /dev/hda: 255 heads, 63 sectors, 2748 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1      2422  19454683+   c  Win95 FAT32 (LBA)
/dev/hda2          2423      2425     24097+  83  Linux
/dev/hda3          2426      2748   2594497+   5  Extended
/dev/hda5          2426      2739   2522173+  83  Linux
/dev/hda6          2740      2748     72261   82  Linux swap

Comment 3 Michael Fulbright 2000-10-06 17:47:33 EDT
What kind of 'automatic partitioning' did you do?  I have not been able to get
this result.
Comment 4 daniel.deimert 2000-10-08 09:26:38 EDT
I can't see why it should matter, but before I installed, the Win95 partition
spanned the entire disk - there was only one partition.  I shrunk the size of
that using Partition Magic 5.0 to make room for a 7.0 install.
I had to do a text-mode install due to PS/2 mouse problems in the graphic
installer.
Then I just selected the workstation install and let the installer partition the
disk as it pleased. 
Comment 5 Michael Fulbright 2000-10-24 16:03:57 EDT
Please let us know if you have any further problems.
Comment 6 openshift-github-bot 2018-02-05 16:54:16 EST
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/ad4bd3f1ef5f653921ccf909a098e5b887bc7d64
Merge pull request #18422 from damemi/iss18016-1

Automatic merge from submit-queue.

Issue 18016: Add infos count to `oc status`

Fix for https://github.com/openshift/origin/issues/18016

Now `oc status` without `-v` will show a count for number of errors, warnings, and info identified. Also refactored this output to reduce redundant switch statements with including infos.

Note You need to log in before you can comment on or make changes to this bug.