Bug 180160 - avahi-daemon fails to start when SELINUX == enforcing
avahi-daemon fails to start when SELINUX == enforcing
Status: CLOSED DUPLICATE of bug 178702
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-06 09:31 EST by Botond Kardos
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 10:14:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Botond Kardos 2006-02-06 09:31:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060202 Fedora/1.5.0.1-2 Firefox/1.5.0.1

Description of problem:
With FC5 test2 + full updates (as of the 5th of january) avahi-daemon, haldeamon and gnome-power-manager fail to start if SELINUX is set to enforcing mode. They are all OK if SELINUX is set to permissive mode.
This gets into /var/log/messages after starting "/usr/sbin/avahi-daemon -D":
avahi-daemon[7584]: Found user 'avahi' (UID 70) and group 'avahi' (GID 70).
avahi-daemon[7584]: Successfully dropped root privileges.
avahi-daemon[7584]: avahi-daemon 0.6.6 starting up.
avahi-daemon[7584]: WARNING: No NSS support for mDNS detected, consider installing nss-mdns!
avahi-daemon[7584]: dbus_bus_get(): Failed to connect to socket /var/run/dbus/system_bus_socket: Permission denied


Version-Release number of selected component (if applicable):
avahi-0.6.6-1

How reproducible:
Always

Steps to Reproduce:
1. Set SELINUX to Enforcing mode
2. Reboot and watch for Avahi and HAL services

  

Actual Results:  Avahi and HAL fail to start

Expected Results:  They should have started up properly

Additional info:

I think this is a SELINUX bug but I didn't find a better place to report it.
Morover I think (but I'm not sure) that avahi and HAL were OK right after the fresh FC5T2 DVD install and they got broken with one of the updates.
Comment 1 Jason Vas Dias 2006-02-06 10:14:18 EST
Yes, this was fixed with selinux-policy-targeted-2.2.6+ ( see bug 178702 ) .

Upgrading to the latest selinux-policy-targeted-2.2.11-1 will fix this problem.


*** This bug has been marked as a duplicate of 178702 ***

Note You need to log in before you can comment on or make changes to this bug.