Bug 1801604 - CD-ROMs disk bus should be validated in the VM wizard like storage disks at the Storage tab
Summary: CD-ROMs disk bus should be validated in the VM wizard like storage disks at t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Ido Rosenzwig
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-11 10:30 UTC by Ido Rosenzwig
Modified: 2020-05-04 11:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:35:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4231 0 None closed Bug 1801604: Add disk validation to virtual hardware on create-vm-wizard 2020-03-05 10:09:57 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:36:01 UTC

Description Ido Rosenzwig 2020-02-11 10:30:00 UTC
Description of problem:
The disk bus of CD-ROMs at the Virtual Hardware tab should be checked if it's valid or recommended - like the disks at the Storage tab. 

Version-Release number of selected component (if applicable):
4.3

How reproducible:
100%

Steps to Reproduce:
1. Open openshift web console : Go to the 'workloads' -> 'Virtual Machines' -> 'Create Virtual Machine'
2. Choose a Windows OS and a source of 'container' or 'URL', the other fields aren't important. ( Don't use a user template )
3. Go to the Virtual Storage Tab 
4. Add a cd-rom 
5. In the interface dropdown you should have 2 options: VirtIO and sata.

Expected results:

- There should be an interface column at the Virtual Storage tab
- The sata choice should be marked as 'not recommended' but can be chosen.
- If sata was chosen a warning message should appear under the Dropdown in the modal.
- If the user saved the changes at the modal along with the sata choice, a warning message should appear below the sata label in the Interface column.
 

Additional info:

NOTE: this bug is not for windows templates, virtIO and sata specific but a general one. I used those specific names to explain the problem as this is the only way to reproduce the bug without creating a user template with custom validations.
Thus, the fix should be general and not Windows,VirtIO and sata specific.

Comment 2 Guohua Ouyang 2020-02-24 07:41:09 UTC
verified on 4.4.0-0.nightly-2020-02-22-102956

Comment 4 errata-xmlrpc 2020-05-04 11:35:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.