Bug 180171 - amaroK crashes on startup
amaroK crashes on startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-06 11:19 EST by Duncan Innes
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-23 12:30:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Duncan Innes 2006-02-06 11:19:07 EST
Description of problem: amaroK crashes on startup.


Version-Release number of selected component (if applicable): amarok-1.3.6-1.fc5


How reproducible: Every time


Steps to Reproduce:
1. Start amarok from command line or icon
  
Actual results: crash


Expected results: amarok should start up normally


Additional info:
[duncan@thinkpad ~]$ amarok
amaroK: [Loader] Starting amarokapp..
amaroK: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.
amarokapp: error while loading shared libraries: libGL.so.1: cannot enable
executable stack as shared object requires: Permission denied
[duncan@thinkpad ~]$ amarokapp
amarokapp: error while loading shared libraries: libGL.so.1: cannot enable
executable stack as shared object requires: Permission denied
[duncan@thinkpad ~]$ rpm -qa | grep amarok
amarok-1.3.6-1.fc5
[duncan@thinkpad ~]$

This has been done after a yum remove and yum install of amarok for added freshness!
Comment 1 Duncan Innes 2006-02-19 08:58:08 EST
Is this worth pursuing?  Or should I wait and test it when test3 is released?

I'm running the latest rawhide and still get exactly the same problems.

Duncan
Comment 2 Aurelien Bompard 2006-02-22 13:18:31 EST
I've just built amarok 1.4beta1 for FC5, do you still have this problem with it ?
Comment 3 Duncan Innes 2006-02-23 04:43:45 EST
I'm installing from extras-development repo via yum, so I'm only getting version
1.3.6-1.fc5

Is this what you've just built?  Or do you want me to try building 1.4beta1 from
source?  I don't think I'm good enough to try compiling from source.

I've just re-installed it and run it under KDE and it's working perfectly.

This is the first time I've run it under KDE though - all other times were under
Gnome.  Is this relevant?

I can't actually get Gnome working at all at the moment due to a metacity
problem, so I can't test under Gnome.
Comment 4 Aurelien Bompard 2006-02-23 04:57:49 EST
Maybe it's not yet indexed, but version 1.4beta1 is built for devel :
http://download.fedora.redhat.com/pub/fedora/linux/extras/development/i386/amarok-1.4-0.7.beta1.fc5.i386.rpm

Running it from GNOME may have caused the crash, can you go to "Configuration" >
"Configure Amarok" > "Engine" and tell me which one is selected ?
Thanks
Comment 5 Duncan Innes 2006-02-23 08:28:59 EST
Sorry, can't do that - I've just upgraded the machine to test 3 via the
downloaded DVD image.

I ran amarok from Gnome and it worked.

I'm now uninstalling it, reinstalling it and trying again just to verify that
everything is OK.

Perhaps something to do with my broken Gnome under test 2?
Comment 6 Duncan Innes 2006-02-23 08:43:10 EST
Second thoughts, it's NOT working under Gnome.  The flash screen appears, then
the window is up for a second or two before disappearing.

[duncan@localhost ~]$ amarok
amaroK: [Loader] Starting amarokapp..
amaroK: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.
QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to layout for
PlaylistWindow/PlaylistWindow
[duncan@localhost ~]$ X Error: BadWindow (invalid Window parameter) 3
  Major opcode:  7
  Minor opcode:  0
  Resource id:  0x3400015

[duncan@localhost ~]$

Is there a log file I can post at all?

I'll get the engine in a second once I boot into KDE to run it.
Comment 7 Duncan Innes 2006-02-23 08:59:10 EST
Further complications:

Amarok is crashing under KDE too now - with exactly the same errors as under Gnome.

Could this be to do with the fact that this machine was originally installed as
FC5t2 then upgraded daily via yum before being upgraded to FC5t3?  Just
wondering is the yum updates would have cracked anything badly enough that
things just won't work any more.  Do I need to do a fresh install of FC5t3 from DVD?

I'll install your beta RPM and see how it goes.
Comment 8 Duncan Innes 2006-02-23 09:07:06 EST
Can't install your rpm due to the following deps:

[root@localhost Desktop]# rpm -Uvh amarok-1.4-0.7.beta1.fc5.i386.rpm
error: Failed dependencies:
        libakode.so.2 is needed by amarok-1.4-0.7.beta1.fc5.i386
        libifp.so.4 is needed by amarok-1.4-0.7.beta1.fc5.i386
        libtunepimp.so.3 is needed by amarok-1.4-0.7.beta1.fc5.i386
[root@localhost Desktop]#

Not sure where these come from - sorry.
Comment 9 Aurelien Bompard 2006-02-23 09:30:11 EST
Those are provided by akode, libifp, and libtunepimp. Use yum localinstall to
install the amarok rpm, it will resolve the deps.
Comment 10 Duncan Innes 2006-02-23 11:59:33 EST
Right - I got it all installed after a rather mamoth yum update.

amarok now starting up perfectly and playing as expected.

Engine is GStreamer 0.10 Engine with alsasink output plugin.

Will amarok 1.4 be in the final release then?

Thanks
Comment 11 Aurelien Bompard 2006-02-23 12:30:20 EST
> Will amarok 1.4 be in the final release then?

Yes. Amarok 1.4 is the first release to work with gstreamer 0.10, and 1.4 final
should be out before FC5.

The crash may have come from the previous amarok package being compiled with
gstreamer 0.8, which is gone from rawhide. (or not).

Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.