Bug 1801741 - The pod donut ring should have a single tooltip rather than one for each slice in the donut chart.
Summary: The pod donut ring should have a single tooltip rather than one for each slic...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Karthik Jeeyar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-11 14:57 UTC by Karthik Jeeyar
Modified: 2020-05-04 11:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: On hovering the pod donut in the topology/sidebar component the tooltip is show for each slice, since we have tooltips for each status. Consequence: Due to multiple tooltips, users had to hover on each status to know its details indivudually. Fix: Instead of having multiple tooltips, we made a single tooltip to contain all the information for that pod. Result: User can now hover on a POD, to know more about all the status of it rather than hovering on each slice of the donut.
Clone Of:
Environment:
Last Closed: 2020-05-04 11:35:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
current tooltip (68.57 KB, image/png)
2020-02-11 14:57 UTC, Karthik Jeeyar
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4286 0 None closed Bug 1801741: Update tooltip to show all the status on hovering a pod donut chart 2020-04-20 09:47:08 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:36:01 UTC

Description Karthik Jeeyar 2020-02-11 14:57:44 UTC
Created attachment 1662459 [details]
current tooltip

Description of problem:

The pod donut ring should have a single tooltip rather than one for each slice in the donut chart.

Version-Release number of selected component (if applicable):

4.4


Steps to Reproduce:

1.Hover on the pod donut ring in topology, sidepanel and in details page.


Actual results:

The tooltip shows only the status of single slice

Expected results:

On hovering the pod donut slice, it should show all the status of the slices in the donut chart

Comment 2 Gajanan More 2020-03-02 11:57:56 UTC
https://issues.redhat.com/browse/ODC-2969 verified by Gajanan More

Comment 4 errata-xmlrpc 2020-05-04 11:35:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.