Bug 1801752 - Knative services sidebar doesn't show associated pod list
Summary: Knative services sidebar doesn't show associated pod list
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jaivardhan Kumar
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1806090
TreeView+ depends on / blocked
 
Reported: 2020-02-11 15:13 UTC by Jaivardhan Kumar
Modified: 2020-05-04 11:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: There isn't any way to navigate to the pods resource from selecting the knative service in topology. Consequence: User have to go through multiple clicks to find associated pods for service Fix: Show sidebar for selected service with list of pods along with link to view logs Result: Knative service sidebar has list of pods along with link to view logs
Clone Of:
: 1806090 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:35:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
Knative services sidebar does show associated pod list [?] N (70.61 KB, image/png)
2020-02-24 08:56 UTC, spathak@redhat.com
no flags Details
Knative services sidebar show associated pod list (87.01 KB, image/png)
2020-02-25 11:09 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4284 None closed Bug 1801752: Fix knative sidebar to show podlist in topology sidebar 2020-06-30 17:23:17 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:35:49 UTC

Description Jaivardhan Kumar 2020-02-11 15:13:08 UTC
Description of problem:
Knative services sidebar doesn't show associated pod list

Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Install OpenShift Serverless operator
2. Create a knative service with DevConsole Add flow
3. Go topology view 
3. Once Revisions are created, click on knative Service
4. check the sidebar for knative service

Actual results:
Knative Service sidebar doesn't show associated pods

Expected results:
Knative Service sidebar should show associated pods

Comment 5 spathak@redhat.com 2020-02-24 08:56:20 UTC
Created attachment 1665344 [details]
Knative services sidebar does show associated pod list   [?] N

Comment 6 spathak@redhat.com 2020-02-24 08:58:58 UTC
Verified on build : 4.4.0-0.ci-2020-02-23-124819
Chrome browser: 76.0.3809.132

Comment 7 spathak@redhat.com 2020-02-25 11:09:14 UTC
Created attachment 1665616 [details]
Knative services sidebar show associated pod list

Comment 9 errata-xmlrpc 2020-05-04 11:35:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.