Bug 1801762 - API Service Refreshes the App State
Summary: API Service Refreshes the App State
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-11 15:32 UTC by Andrew Ballantyne
Modified: 2020-05-04 11:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:35:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4285 0 None closed Bug 1801762: Don't re-run discovery on modified APIService 2020-12-28 21:53:28 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:35:49 UTC

Description Andrew Ballantyne 2020-02-11 15:32:19 UTC
Description of problem:
There is an intermittent issue where the OpenShift Console will re-evaluate and update elements when nothing has changed locally. It rarely happens, but when it does it spams the console, in dev mode, with details about feature availability.

This could potentially lead to a performance issue.

Version-Release number of selected component (if applicable):
OpenShift Console 4.4

How reproducible:
Low, it doesn't seem to happen on all clusters. But once it happens it's always happening it seems.

Steps to Reproduce:
1. Login to a cluster that has the issue
2. Open the developer console

Actual results:
See the constant echoing of the features.

Expected results:
Only when changes happen should it echo the features and re-render the app.

Additional info:
Sam believes it is related to the watcher on API Service: https://github.com/spadgett/console/blob/e57533e6891bf9b28753550de18dac93c0e01192/frontend/public/actions/k8s.ts#L281-L304

The Cluster (for the next day or so) that is having the issue is:
https://coreos.slack.com/archives/CHGU4P8UU/p1581321442430200

Comment 2 Yadan Pei 2020-02-13 07:55:36 UTC
Hi Sam,

Can you tell me how can I verify this bug? Didn't figure out a way to verify, sorry

Comment 3 Yadan Pei 2020-02-20 05:57:03 UTC
Andrew,

Can you tell me how to verify the bug?

Comment 4 Andrew Ballantyne 2020-02-20 15:07:21 UTC
Hi Yadan,

This ticket came to be when Sam and I were discussing issues around how the cluster would constantly retrigger itself. I am not sure how to test this as it was a hugely intermittent issue - we went several weeks in between conversations about it before it showed up again.

Testing it via the UI might actually be quite difficult as well, as the main tell was a console spam in dev-mode. Not sure if Sam has a better stance... the code change to make this "fixed" was a minor diff change to the update logic so it didn't retrigger on every update; even when there are not changes to propagate.

Since the cluster that was having the issue is now gone, I am unsure if we can effectively test this.

There was a minor flicker in the UI when the app reloaded the feature flags (as a result of the update logic triggering), but it's hardly a test-case I can provide with any detail.

In my opinion, I think just looking at any specific Pipeline Details Page and for a brief moment or two to see if the UI flickers is our best test-case. If it does not than we can assume it's fixed. If it happens again, we'll just open another bug as it's really an intermittent issue.

Comment 5 Yadan Pei 2020-02-21 07:10:16 UTC
Thank you so much Andrew,

I checked Pipeline Details page in developer console & admin console, even after we triggered pipeline runs. Also I monitored some other pages as well I don't see flickers happen.

Will move to VERIFIED

4.4.0-0.nightly-2020-02-20-215232

Comment 8 errata-xmlrpc 2020-05-04 11:35:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.