Bug 1801797 - Profiles are not deleted on node deletion.
Summary: Profiles are not deleted on node deletion.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node Tuning Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jiří Mencák
QA Contact: Simon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-11 16:16 UTC by Jiří Mencák
Modified: 2020-05-04 11:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:35:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-node-tuning-operator pull 115 0 None closed Bug 1801797: Pod-label support optimizations. 2020-05-11 14:45:43 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:35:49 UTC

Description Jiří Mencák 2020-02-11 16:16:48 UTC
Description of problem:
NTO does not remove profiles for nodes which were removed from the cluster.

Version-Release number of selected component (if applicable):
Any 4.4 release.

How reproducible:
Always

Steps to Reproduce:
1. Install OCP
2. oc get nodes
3. oc get profiles -n openshift-cluster-node-tuning-operator # There should 1 profile per node.
4. Delete one worker node.
5. The tuned profile should be removed too, but is not.

Actual results:
The tuned profile not removed on node deletion.


Expected results:
The tuned profile removed on node deletion.


Additional info:

Comment 1 Jiří Mencák 2020-02-12 07:59:08 UTC
Fixed in: 4.4.0-0.nightly-2020-02-12-064521

$ oc get clusterversion
NAME      VERSION   AVAILABLE   PROGRESSING   SINCE   STATUS
version             False       True          47m     Unable to apply 4.4.0-0.nightly-2020-02-12-064521: the cluster operator monitoring has not yet successfully rolled out

$ oc get nodes
NAME                                         STATUS   ROLES    AGE   VERSION
ip-10-0-132-176.eu-west-1.compute.internal   Ready    worker   33m   v1.17.1
ip-10-0-140-162.eu-west-1.compute.internal   Ready    master   44m   v1.17.1
ip-10-0-145-151.eu-west-1.compute.internal   Ready    worker   33m   v1.17.1
ip-10-0-148-240.eu-west-1.compute.internal   Ready    master   42m   v1.17.1
ip-10-0-162-113.eu-west-1.compute.internal   Ready    master   42m   v1.17.1

$ oc project openshift-cluster-node-tuning-operator
Now using project "openshift-cluster-node-tuning-operator" on server "https://api.jm20200212.perf-testing.devcluster.openshift.com:6443".

$ oc get profiles
NAME                                         AGE
ip-10-0-132-176.eu-west-1.compute.internal   33m
ip-10-0-140-162.eu-west-1.compute.internal   41m
ip-10-0-145-151.eu-west-1.compute.internal   33m
ip-10-0-148-240.eu-west-1.compute.internal   41m
ip-10-0-162-113.eu-west-1.compute.internal   41m

$ oc delete node ip-10-0-132-176.eu-west-1.compute.internal
node "ip-10-0-132-176.eu-west-1.compute.internal" deleted

$ oc get profiles
NAME                                         AGE
ip-10-0-140-162.eu-west-1.compute.internal   41m
ip-10-0-145-151.eu-west-1.compute.internal   34m
ip-10-0-148-240.eu-west-1.compute.internal   41m
ip-10-0-162-113.eu-west-1.compute.internal   41m

Comment 2 Simon 2020-02-18 20:50:39 UTC
Retest positive!

oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.4.0-0.nightly-2020-02-16-221315   True        False         29h     Cluster version is 4.4.0-0.nightly-2020-02-16-221315

oc get nodes
NAME                                         STATUS   ROLES    AGE   VERSION
ip-10-0-129-127.us-west-2.compute.internal   Ready    master   29h   v1.17.1
ip-10-0-133-9.us-west-2.compute.internal     Ready    worker   29h   v1.17.1
ip-10-0-148-251.us-west-2.compute.internal   Ready    master   29h   v1.17.1
ip-10-0-156-149.us-west-2.compute.internal   Ready    worker   29h   v1.17.1
ip-10-0-164-12.us-west-2.compute.internal    Ready    master   29h   v1.17.1
ip-10-0-175-141.us-west-2.compute.internal   Ready    worker   29h   v1.17.1

oc get profiles -n openshift-cluster-node-tuning-operator 
NAME                                         AGE
ip-10-0-129-127.us-west-2.compute.internal   29h
ip-10-0-133-9.us-west-2.compute.internal     29h
ip-10-0-148-251.us-west-2.compute.internal   29h
ip-10-0-156-149.us-west-2.compute.internal   29h
ip-10-0-164-12.us-west-2.compute.internal    29h
ip-10-0-175-141.us-west-2.compute.internal   29h

oc delete node ip-10-0-133-9.us-west-2.compute.internal
node "ip-10-0-133-9.us-west-2.compute.internal" deleted

oc get nodes
NAME                                         STATUS   ROLES    AGE   VERSION
ip-10-0-129-127.us-west-2.compute.internal   Ready    master   29h   v1.17.1
ip-10-0-148-251.us-west-2.compute.internal   Ready    master   29h   v1.17.1
ip-10-0-156-149.us-west-2.compute.internal   Ready    worker   29h   v1.17.1
ip-10-0-164-12.us-west-2.compute.internal    Ready    master   29h   v1.17.1
ip-10-0-175-141.us-west-2.compute.internal   Ready    worker   29h   v1.17.1

oc get profiles -n openshift-cluster-node-tuning-operator 
NAME                                         AGE
ip-10-0-129-127.us-west-2.compute.internal   29h
ip-10-0-148-251.us-west-2.compute.internal   29h
ip-10-0-156-149.us-west-2.compute.internal   29h
ip-10-0-164-12.us-west-2.compute.internal    29h
ip-10-0-175-141.us-west-2.compute.internal   29h

Comment 5 errata-xmlrpc 2020-05-04 11:35:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.