Bug 1801820 - [abrt] gnome-shell: js::gc::TenuredCell::writeBarrierPre(js::gc::TenuredCell*)(): gnome-shell killed by SIGSEGV
Summary: [abrt] gnome-shell: js::gc::TenuredCell::writeBarrierPre(js::gc::TenuredCell*...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 32
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:3b79095c4dcca788d5f7fd0ea08...
: 1811254 (view as bug list)
Depends On:
Blocks: F32BetaBlocker F32BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-02-11 16:55 UTC by Mikhail
Modified: 2020-03-08 08:44 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-06 20:49:17 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (59.03 KB, text/plain)
2020-02-11 16:55 UTC, Mikhail
no flags Details
File: core_backtrace (160.96 KB, text/plain)
2020-02-11 16:55 UTC, Mikhail
no flags Details
File: cpuinfo (2.50 KB, text/plain)
2020-02-11 16:55 UTC, Mikhail
no flags Details
File: dso_list (25.97 KB, text/plain)
2020-02-11 16:55 UTC, Mikhail
no flags Details
File: environ (1.56 KB, text/plain)
2020-02-11 16:55 UTC, Mikhail
no flags Details
File: limits (1.29 KB, text/plain)
2020-02-11 16:55 UTC, Mikhail
no flags Details
File: maps (160.11 KB, text/plain)
2020-02-11 16:55 UTC, Mikhail
no flags Details
File: mountinfo (2.52 KB, text/plain)
2020-02-11 16:55 UTC, Mikhail
no flags Details
File: open_fds (11.54 KB, text/plain)
2020-02-11 16:55 UTC, Mikhail
no flags Details
File: proc_pid_status (1.34 KB, text/plain)
2020-02-11 16:55 UTC, Mikhail
no flags Details
File: var_log_messages (724 bytes, text/plain)
2020-02-11 16:55 UTC, Mikhail
no flags Details
gnome-shell backtrace (934.47 KB, text/plain)
2020-02-12 16:28 UTC, Mikhail
no flags Details
gnome-shell backtrace with gjs-1.63.91-1.fc33.x86_64 (958.87 KB, text/plain)
2020-02-20 17:40 UTC, Mikhail
no flags Details
system logs (372.33 KB, text/plain)
2020-02-20 17:44 UTC, Mikhail
no flags Details
gnome-shell backtrace with gjs-1.63.91-2.fc33.x86_64 (988.60 KB, text/plain)
2020-02-22 15:20 UTC, Mikhail
no flags Details
gnome-shell gdb backtrace (594.65 KB, text/plain)
2020-03-02 18:16 UTC, trr
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab GNOME/gjs - merge_requests 396 None None None 2020-02-28 17:35:05 UTC
GNOME Gitlab GNOME gjs issues 301 None None None 2020-02-28 17:35:05 UTC
GNOME Gitlab GNOME gnome-shell issues 2206 None None None 2020-02-12 16:16:30 UTC

Description Mikhail 2020-02-11 16:55:16 UTC
Description of problem:
Occurs randomly, very annoying

Version-Release number of selected component:
gnome-shell-3.35.90-2.fc32

Additional info:
reporter:       libreport-2.12.0
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/gnome-shell-wayland.service
cmdline:        /usr/bin/gnome-shell
crash_function: js::gc::TenuredCell::writeBarrierPre(js::gc::TenuredCell*)
executable:     /usr/bin/gnome-shell
journald_cursor: s=0f5ff7d2cc2e45db95b9d0da945ef64f;i=21a04;b=fa47c8839d4c425b8c498d40476cc733;m=1567cbeac;t=59e3c1a55b631;x=7abc2834fb1e45a7
kernel:         5.5.0-0.rc7.git0.2.fc32.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 0 (10 frames)
 #0 js::gc::TenuredCell::writeBarrierPre(js::gc::TenuredCell*) at /usr/src/debug/mozjs68-68.4.2-3.fc32.x86_64/dist/include/js/HeapAPI.h:155
 #1 JSObject::writeBarrierPre(JSObject*) at /usr/src/debug/mozjs68-68.4.2-3.fc32.x86_64/vm/JSObject.h:726
 #2 js::InternalBarrierMethods<JSObject*>::preBarrier(JSObject*) at /usr/src/debug/mozjs68-68.4.2-3.fc32.x86_64/gc/Barrier.h:325
 #3 JS::HeapObjectWriteBarriers(JSObject**, JSObject*, JSObject*) at /usr/src/debug/mozjs68-68.4.2-3.fc32.x86_64/gc/Barrier.cpp:190
 #4 js::BarrierMethods<JSObject*>::writeBarriers(JSObject**, JSObject*, JSObject*) at /usr/include/mozjs-68/js/RootingAPI.h:721
 #5 JS::Heap<JSObject*>::writeBarriers(JSObject* const&, JSObject* const&) at /usr/include/mozjs-68/js/RootingAPI.h:355
 #6 JS::Heap<JSObject*>::set(JSObject* const&) at /usr/include/mozjs-68/js/RootingAPI.h:351
 #7 JS::Heap<JSObject*>::operator=(JSObject*&&) at /usr/include/mozjs-68/js/RootingAPI.h:320
 #8 GjsMaybeOwned<JSObject*>::reset() at ../gjs/jsapi-util-root.h:281
 #9 ObjectInstance::discard_wrapper() at ../gi/object.h:355

Comment 1 Mikhail 2020-02-11 16:55:20 UTC
Created attachment 1662493 [details]
File: backtrace

Comment 2 Mikhail 2020-02-11 16:55:23 UTC
Created attachment 1662494 [details]
File: core_backtrace

Comment 3 Mikhail 2020-02-11 16:55:24 UTC
Created attachment 1662495 [details]
File: cpuinfo

Comment 4 Mikhail 2020-02-11 16:55:26 UTC
Created attachment 1662496 [details]
File: dso_list

Comment 5 Mikhail 2020-02-11 16:55:28 UTC
Created attachment 1662497 [details]
File: environ

Comment 6 Mikhail 2020-02-11 16:55:29 UTC
Created attachment 1662498 [details]
File: limits

Comment 7 Mikhail 2020-02-11 16:55:32 UTC
Created attachment 1662499 [details]
File: maps

Comment 8 Mikhail 2020-02-11 16:55:33 UTC
Created attachment 1662500 [details]
File: mountinfo

Comment 9 Mikhail 2020-02-11 16:55:35 UTC
Created attachment 1662501 [details]
File: open_fds

Comment 10 Mikhail 2020-02-11 16:55:36 UTC
Created attachment 1662502 [details]
File: proc_pid_status

Comment 11 Mikhail 2020-02-11 16:55:38 UTC
Created attachment 1662503 [details]
File: var_log_messages

Comment 12 Mikhail 2020-02-12 16:17:20 UTC
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: clutter_actor_destroy: assertion 'CLUTTER_IS_ACTOR (self)' failed
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: == Stack trace for context 0x55f55b4f84d0 ==
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #0   55f55f5d2908 i   resource:///org/gnome/shell/ui/screenShield.js:337 (29021390c088 @ 21)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #1   55f55f5d2868 i   resource:///org/gnome/shell/ui/screenShield.js:332 (290213907f88 @ 23)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #2   55f55f5d27d0 i   resource:///org/gnome/shell/ui/screenShield.js:246 (290213907cb8 @ 27)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #3   55f55f5d2720 i   resource:///org/gnome/shell/ui/messageTray.js:889 (270e954772e0 @ 175)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #4   55f55f5d2678 i   resource:///org/gnome/shell/ui/windowAttentionHandler.js:100 (290213900cb8 @ 148)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #5   55f55f5d25d8 i   resource:///org/gnome/shell/ui/windowAttentionHandler.js:71 (290213900a60 @ 12)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #6   55f55f5d2520 i   resource:///org/gnome/shell/ui/main.js:613 (338fa7fcc880 @ 244)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #7   55f55f5d2470 i   resource:///org/gnome/shell/ui/workspace.js:2005 (3610a27d100 @ 93)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #8   7ffccb567150 b   self-hosted:1011 (3610a2ee718 @ 454)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #9   55f55f5d23c8 i   resource:///org/gnome/shell/ui/workspace.js:377 (3610a275cb8 @ 48)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #10   55f55f5d2338 i   resource:///org/gnome/shell/ui/workspace.js:412 (3610a275f88 @ 17)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #11   7ffccb568e70 b   self-hosted:1011 (3610a2ee718 @ 454)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: == Stack trace for context 0x55f55b4f84d0 ==
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #0   7ffccb563110 b   resource:///org/gnome/gjs/modules/overrides/GObject.js:571 (338fa7fa3448 @ 25)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #1   55f55f5d2908 i   resource:///org/gnome/shell/ui/screenShield.js:343 (29021390c088 @ 140)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #2   55f55f5d2868 i   resource:///org/gnome/shell/ui/screenShield.js:332 (290213907f88 @ 23)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #3   55f55f5d27d0 i   resource:///org/gnome/shell/ui/screenShield.js:246 (290213907cb8 @ 27)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #4   55f55f5d2720 i   resource:///org/gnome/shell/ui/messageTray.js:889 (270e954772e0 @ 175)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #5   55f55f5d2678 i   resource:///org/gnome/shell/ui/windowAttentionHandler.js:100 (290213900cb8 @ 148)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #6   55f55f5d25d8 i   resource:///org/gnome/shell/ui/windowAttentionHandler.js:71 (290213900a60 @ 12)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #7   55f55f5d2520 i   resource:///org/gnome/shell/ui/main.js:613 (338fa7fcc880 @ 244)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #8   55f55f5d2470 i   resource:///org/gnome/shell/ui/workspace.js:2005 (3610a27d100 @ 93)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: Object .Gjs_ui_messageTray_NotificationApplicationPolicy (0x55f55ed64aa0), has been already deallocated — impossible to access it. This might be caused by the object having been destroyed from C code using something such as destroy(), dispose(), or remove() vfuncs.
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #9   7ffccb567150 b   self-hosted:1011 (3610a2ee718 @ 454)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #10   55f55f5d23c8 i   resource:///org/gnome/shell/ui/workspace.js:377 (3610a275cb8 @ 48)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #11   55f55f5d2338 i   resource:///org/gnome/shell/ui/workspace.js:412 (3610a275f88 @ 17)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: #12   7ffccb568e70 b   self-hosted:1011 (3610a2ee718 @ 454)
Feb 12 21:03:08 localhost.localdomain gnome-shell[352315]: JS ERROR: Error: Argument 'instance' (type interface) may not be null
                                                           _init/GObject.Object.prototype.disconnect@resource:///org/gnome/gjs/modules/overrides/GObject.js:571:24
                                                           _removeSource@resource:///org/gnome/shell/ui/screenShield.js:343:23
                                                           _onSourceDestroy@resource:///org/gnome/shell/ui/screenShield.js:332:14
                                                           _sourceAdded/obj.sourceDestroyId<@resource:///org/gnome/shell/ui/screenShield.js:246:18
                                                           destroy@resource:///org/gnome/shell/ui/messageTray.js:889:14
                                                           destroy@resource:///org/gnome/shell/ui/windowAttentionHandler.js:100:15
                                                           _init/<@resource:///org/gnome/shell/ui/windowAttentionHandler.js:71:61
                                                           activateWindow@resource:///org/gnome/shell/ui/main.js:613:16
                                                           _onCloneSelected@resource:///org/gnome/shell/ui/workspace.js:2005:14
                                                           _activate@resource:///org/gnome/shell/ui/workspace.js:377:14
                                                           _onClicked@resource:///org/gnome/shell/ui/workspace.js:412:14
Feb 12 21:03:10 localhost.localdomain kernel: gnome-shell[352315]: segfault at 10 ip 00007fe09d8a7add sp 00007ffccb5694d0 error 4 in libmozjs-68.so.0.0.0[7fe09d39b000+8ee000]
Feb 12 21:03:10 localhost.localdomain kernel: Code: 45 d8 64 48 33 04 25 28 00 00 00 75 3e 48 83 c4 18 41 5c 41 5d 41 5e 5d c3 0f 1f 40 00 48 89 f0 48 25 00 f0 ff ff 48 8b 40 08 <8b> 50 10 85 d2 74 bf 48 8b 78 08 48 89 75 d0 48 8d 15 71 56 3e 00
Feb 12 21:03:10 localhost.localdomain audit[352315]: ANOM_ABEND auid=1000 uid=1000 gid=1000 ses=7 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=352315 comm="gnome-shell" exe="/usr/bin/gnome-shell" sig=11 res=1

Comment 13 Mikhail 2020-02-12 16:28:20 UTC
Created attachment 1662724 [details]
gnome-shell backtrace

Comment 14 Fedora Blocker Bugs Application 2020-02-12 16:32:19 UTC
Proposed as a Blocker and Freeze Exception for 32-beta by Fedora user mikhail using the blocker tracking app because:

 Occurs randomly, very annoying.
It interferes with performing any tasks on the computer.
Every time when Gnome crashes, all unsaved data is lost.

Comment 15 František Zatloukal 2020-02-17 11:06:00 UTC
It's probably gjs crashing on GC: https://gitlab.gnome.org/GNOME/gjs/issues/301

Comment 16 Geoffrey Marr 2020-02-17 19:32:30 UTC
Discussed during the 2020-02-17 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedFreezeException" and to delay the classification of this bug as a blocker was made as this is potentially a blocker, but we can't make a definite determination yet as there is insufficient information on how common the issue is. However, as a Shell crash under active investigation upstream we're at least willing to grant it freeze exception status; it's definitely a good idea to fix these for the live image if possible.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-02-17/f32-blocker-review.2020-02-17-17.02.txt

Comment 17 František Zatloukal 2020-02-18 20:43:21 UTC
Should be fixed in gjs-1.63.91-1.fc32 . 

Mikhail, can you try please? Thanks!

Comment 18 Mikhail 2020-02-20 17:40:40 UTC
Created attachment 1664459 [details]
gnome-shell backtrace with gjs-1.63.91-1.fc33.x86_64

$ rpm -qa | grep gjs
gjs-1.63.91-1.fc33.x86_64
gjs-debugsource-1.63.91-1.fc33.x86_64
gjs-debuginfo-1.63.91-1.fc33.x86_64


Unfortunately, the crashes still continue happens

Comment 19 Mikhail 2020-02-20 17:44:38 UTC
Created attachment 1664460 [details]
system logs

Comment 20 Adam Williamson 2020-02-20 18:35:33 UTC
openQA just hit this in the middle of the printing test, on today's Fedora 32 compose (Fedora-32-20200220.n.0):

https://openqa.fedoraproject.org/tests/524150

the test fails because, shortly after it switches back from a VT to the desktop (and enters password at a couple of authentication prompts that shouldn't happen - that's https://gitlab.gnome.org/GNOME/gnome-software/issues/582 ), GNOME just crashes. Looking at the crash logs - https://openqa.fedoraproject.org/tests/524150/file/desktop_printing-spoolabrt.tar.gz - the traceback looks exactly the same as this one. This compose definitely has gjs-1.63.91-1.fc32, so confirmed that 1.63.91 doesn't seem to fix this. Also, with Mikhail still hitting it and random openQA tests running into it, I'm inclined to vote +1 blocker.

Comment 21 František Zatloukal 2020-02-21 08:53:24 UTC
So, there is another fix attempt upstream: https://gitlab.gnome.org/GNOME/gjs/merge_requests/396

I've created COPR with patch applied for easier testing: https://copr.fedorainfracloud.org/coprs/frantisekz/gjs-mr396/ 

Unfortunately, there is no F32 support in COPR right now, but F33 rpm should install just fine, so, if anybody can try if this fixes the issue?

# dnf update "https://download.copr.fedorainfracloud.org/results/frantisekz/gjs-mr396/fedora-rawhide-x86_64/01247905-gjs/gjs-1.63.91-2.fc33.x86_64.rpm"
# reboot

Comment 22 Mikhail 2020-02-22 15:20:01 UTC
Created attachment 1665048 [details]
gnome-shell backtrace with gjs-1.63.91-2.fc33.x86_64

$ rpm -qa | grep gjs
gjs-debuginfo-1.63.91-2.fc33.x86_64
gjs-debugsource-1.63.91-2.fc33.x86_64
gjs-1.63.91-2.fc33.x86_64

Unfortunately, gnome-shell still crashes even with gjs-1.63.91-2

Comment 23 Michael Catanzaro 2020-02-24 14:31:45 UTC
+1 blocker

Comment 24 František Zatloukal 2020-02-24 20:30:04 UTC
Discussed during the 2020-02-24 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made:

"No part of any release-blocking desktop's panel (or equivalent) configuration may crash on startup or be entirely non-functional.” We find this appropriate considering that the desktop is “entirely non-functional” after this crash occurs..

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2020-02-24/f32-blocker-review.2020-02-24-17.00.log.txt

Comment 25 thominex 2020-02-27 19:50:53 UTC
Similar problem has been detected:

Steps to reproduce:

1- On a xorg session, logout and select wayland session
2- Log in
3- Something crashes

reporter:       libreport-2.12.0
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/gnome-shell-x11.service
cmdline:        /usr/bin/gnome-shell
crash_function: js::gc::TenuredCell::writeBarrierPre(js::gc::TenuredCell*)
executable:     /usr/bin/gnome-shell
journald_cursor: s=cdc1a346bb5c4691a8b63e5f14d21a57;i=a217b;b=b229a0d17dff40b2b39059becfe6c0ed;m=1cb8e0611;t=59f93edb75b01;x=cef8126cbec8c73c
kernel:         5.6.0-0.rc3.git0.1.fc32.x86_64
package:        gnome-shell-3.35.91-1.fc32
reason:         gnome-shell killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 26 Adam Williamson 2020-02-28 17:39:47 UTC
https://koji.fedoraproject.org/koji/taskinfo?taskID=41991214 is a scratch build with both MR #396 and the further change suggested by Jan Steffens in https://gitlab.gnome.org/GNOME/gjs/-/merge_requests/396#note_726228 . Can folks see if that finally does the trick?

Comment 27 Adam Williamson 2020-02-29 01:33:32 UTC
FWIW I've been running it all day and my session hasn't crashed, but this bug is very 'unreliable' for me - I don't hit it for days and then I get three crashes in a row. So hard to be sure.

Comment 28 trr 2020-03-02 14:16:38 UTC
Can I get new packages/binaries for testing?
Just today locked my gnome-session and it crashed.

Comment 29 Adam Williamson 2020-03-02 15:57:06 UTC
See comment #26.

Comment 30 Mikhail 2020-03-02 16:46:20 UTC
(In reply to Adam Williamson from comment #29)
> See comment #26.

That strange because in comment https://bugzilla.redhat.com/show_bug.cgi?id=1801820#c21 greater version 1.63.91-2

Comment 31 František Zatloukal 2020-03-02 16:53:29 UTC
(In reply to Mikhail from comment #30)
> (In reply to Adam Williamson from comment #29)
> > See comment #26.
> 
> That strange because in comment
> https://bugzilla.redhat.com/show_bug.cgi?id=1801820#c21 greater version
> 1.63.91-2

Yeah, sorry, I am using different release numbers for custom copr builds than Adam. You'll get the same code with 1.63.91-3 from my repo as Adam posted in comment #26 :)

Or you can wait for gjs-1.63.92-1, should hit Fedora repos (rawhide/f32-testing) in a day or two.

Comment 32 Adam Williamson 2020-03-02 17:25:14 UTC
the release numbers of non-official builds are always pretty notional, pay more attention to the dates and descriptions than the numbers.

I usually add a patch level (i.e. go from -1 to -1.1 then -1.2 then -1.3... or -2 to -2.1, 2.2, 2.3...) when I do non-official builds, to ensure the next official build overrides them. Frantisek didn't do that for his.

Comment 33 trr 2020-03-02 18:16:56 UTC
Created attachment 1667042 [details]
gnome-shell gdb backtrace

Repeated bug again (gnome-shell failes after locking screen).

Comment 34 Adam Williamson 2020-03-02 18:19:47 UTC
trr: at a quick glance that does not look like the same crash. The backtrace runs through clutter and not through the same gjs stuff that this bug is for. your crash:

                #0  0x00007f9d276a59f5 raise (libc.so.6 + 0x3c9f5)
                #1  0x000056345c6523cb dump_gjs_stack_on_signal_handler (gnome-shell + 0x33cb)
                #2  0x00007f9d276a5a80 __restore_rt (libc.so.6 + 0x3ca80)
                #3  0x00007f9d28484817 g_log_structured_array (libglib-2.0.so.0 + 0x59817)
                #4  0x00007f9d28484c29 g_log_default_handler (libglib-2.0.so.0 + 0x59c29)
                #5  0x000056345c6520ae default_log_handler (gnome-shell + 0x30ae)
                #6  0x00007f9d28484e79 g_logv (libglib-2.0.so.0 + 0x59e79)
                #7  0x00007f9d28485113 g_log (libglib-2.0.so.0 + 0x5a113)
                #8  0x00007f9d27ad50d0 clutter_box_layout_allocate (libmutter-clutter-6.so.0 + 0x6f0d0)
                #9  0x00007f9d27619531 st_viewport_allocate (libst-1.0.so + 0x4a531)
                #10 0x00007f9d27ac2bbb clutter_actor_set_animatable_property (libmutter-clutter-6.so.0 + 0x5cbbb)
                #11 0x00007f9d27ac632e _clutter_actor_create_transition (libmutter-clutter-6.so.0 + 0x6032e)
                #12 0x00007f9d27ac6e40 clutter_actor_allocate (libmutter-clutter-6.so.0 + 0x60e40)
...etc

this bug:

#0 js::gc::TenuredCell::writeBarrierPre(js::gc::TenuredCell*) at /usr/src/debug/mozjs68-68.4.2-3.fc32.x86_64/dist/include/js/HeapAPI.h:155
 #1 JSObject::writeBarrierPre(JSObject*) at /usr/src/debug/mozjs68-68.4.2-3.fc32.x86_64/vm/JSObject.h:726
 #2 js::InternalBarrierMethods<JSObject*>::preBarrier(JSObject*) at /usr/src/debug/mozjs68-68.4.2-3.fc32.x86_64/gc/Barrier.h:325
 #3 JS::HeapObjectWriteBarriers(JSObject**, JSObject*, JSObject*) at /usr/src/debug/mozjs68-68.4.2-3.fc32.x86_64/gc/Barrier.cpp:190
 #4 js::BarrierMethods<JSObject*>::writeBarriers(JSObject**, JSObject*, JSObject*) at /usr/include/mozjs-68/js/RootingAPI.h:721
 #5 JS::Heap<JSObject*>::writeBarriers(JSObject* const&, JSObject* const&) at /usr/include/mozjs-68/js/RootingAPI.h:355
 #6 JS::Heap<JSObject*>::set(JSObject* const&) at /usr/include/mozjs-68/js/RootingAPI.h:351
 #7 JS::Heap<JSObject*>::operator=(JSObject*&&) at /usr/include/mozjs-68/js/RootingAPI.h:320
...etc

Comment 35 Adam Williamson 2020-03-02 18:52:49 UTC
Setting this to POST as a fix has been accepted upstream, an F32 update is impending.

Comment 36 Fedora Update System 2020-03-02 20:29:37 UTC
FEDORA-2020-49097e4ddc has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-49097e4ddc

Comment 37 Fedora Update System 2020-03-03 16:10:10 UTC
gjs-1.63.92-1.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-49097e4ddc

Comment 38 František Zatloukal 2020-03-04 16:44:33 UTC
gjs-1.63.92-1.fc32 seems to fix the issue.

Comment 39 Fedora Update System 2020-03-06 20:49:17 UTC
gjs-1.63.92-1.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.

Comment 40 Alberto Ruiz 2020-03-06 23:55:49 UTC
*** Bug 1811254 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.