Bug 1801857 - Re-Enable Pipeline Builder
Summary: Re-Enable Pipeline Builder
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-11 18:38 UTC by Andrew Ballantyne
Modified: 2020-05-04 11:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:35:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4240 None closed Bug 1801857: Cleanup Pipeline Builder 2020-03-02 06:57:35 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:35:49 UTC

Description Andrew Ballantyne 2020-02-11 18:38:34 UTC
Description of problem:
There were many rough edges to the Pipeline Builder at feature freeze. It was disabled from the UI to prevent easy access that would lead to an undesirable experience.

Version-Release number of selected component (if applicable):
OpenShift 4.4

How reproducible:


Steps to Reproduce:
1. Install the Pipeline Operator
2. Navigate to Pipelines
3. Either Create a new Pipeline or Edit an existing Pipeline

Actual results:
No way to get to the Pipeline Builder

Expected results:
The create button to take you to the Pipeline Builder (not the edit YAML) and for there to be a way to edit an existing Pipeline with the Pipeline Builder.

Additional info:
It's been a hidden route since feature freeze, so this is more bug fixing and re-enabling the buttons in the UI.

Comment 4 Ruchir Garg 2020-03-02 06:38:42 UTC
Bulk assigning all to Gajanan for verification.

Comment 5 Gajanan More 2020-03-02 07:21:33 UTC
Verified by Sanket Pathak
Equivalent Jira: https://issues.redhat.com/browse/ODC-2854

Comment 7 errata-xmlrpc 2020-05-04 11:35:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.