Bug 1801858 - Save button on Pipelines Resources tab is not enabled even if all required fields are filled.
Summary: Save button on Pipelines Resources tab is not enabled even if all required fi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: cvogt
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1811525
TreeView+ depends on / blocked
 
Reported: 2020-02-11 18:44 UTC by Rohit Rai
Modified: 2020-05-04 11:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1811525 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:36:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
Save button on Pipelines Resources tab is enabled even if all required fields are filled. (325.61 KB, video/webm)
2020-03-05 14:38 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4287 None closed Bug 1801858: Separate validation schemas for parameters and resources tab of pipelines details page 2020-04-21 22:15:46 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:36:27 UTC

Description Rohit Rai 2020-02-11 18:44:33 UTC
Description of problem:
Save button on Pipelines Resources tab is not enabled even if all required fields are filled.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Go to resources tab of pipeline details page.
2. Add a new row and fill name and type fields.
3. Even though the data is correctly validated and all required fields on the form is filled, save button is disabled.

Actual results:
Save button is disabled even after filling the form correctly.

Expected results:
Save button should be enabled as soon as the required fields are filled.

Additional info:

Comment 2 Ruchir Garg 2020-03-02 06:38:40 UTC
Bulk assigning all to Gajanan for verification.

Comment 3 spathak@redhat.com 2020-03-05 14:38:13 UTC
Created attachment 1667780 [details]
Save button on Pipelines Resources tab is enabled even if all required fields are filled.

Comment 4 spathak@redhat.com 2020-03-05 14:39:51 UTC
Verified on build : 4.4.0-0.nightly-2020-03-05-014624
Chrome browser: 76.0.3809.132

Comment 6 errata-xmlrpc 2020-05-04 11:36:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.