Bug 1801983 - Monitoring Dashboards: k8s-resources-workloads-namespace don't always set a Type by default
Summary: Monitoring Dashboards: k8s-resources-workloads-namespace don't always set a T...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Andrew Pickering
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-12 03:27 UTC by Yadan Pei
Modified: 2020-05-04 11:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:36:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4346 None closed Bug 1801983: Monitoring Dashboards: Fixes for variable handling and performance 2020-04-22 08:42:47 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:36:27 UTC

Description Yadan Pei 2020-02-12 03:27:48 UTC
Description of problem:
Type should have default Type selected when Namespace is changed

Version-Release number of selected component (if applicable):
    4.4.0-0.nightly-2020-02-11-203858

How reproducible:
Always

Steps to Reproduce:
1. cluster admin view 'k8s-resources-workloads-namespace' dashboard at Monitoring -> Dashboard page
2. Change Namespace to other namespaces like 'openshift-authentication'


Actual results:
2. Only 1 type in Type dropdown, but it's not selected by default, this is different from the behavior in Grafana

Expected results:
2. A type should be always selected by default

Additional info:

Comment 4 Yadan Pei 2020-02-20 05:50:59 UTC
Steps to verify:
1. cluster admin view 'k8s-resources-workloads-namespace' dashboard at Monitoring -> Dashboard page
2. Change Namespace to other namespaces like 'openshift-authentication', Type dropdown is set as 'deployment' by default, when change namespaces in variable dropdown, Type is automatically changed based on resource type in that namespace
3. Change dashboard to 'k8s-resources-workload', when value of Namespace dropdown is changed, Workload & Type are changed accordingly


The reported issue has been fixed, verified on     4.4.0-0.nightly-2020-02-19-041512

Comment 6 errata-xmlrpc 2020-05-04 11:36:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.