Bug 1802034 - Silenced alerts should not show up in the Dashboards page of the console
Summary: Silenced alerts should not show up in the Dashboards page of the console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: David Taylor
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1808059
TreeView+ depends on / blocked
 
Reported: 2020-02-12 08:53 UTC by Lili Cosic
Modified: 2020-07-13 17:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Silence an alert from Monitoring -> Alerts -> choose one firing alert -> click kebab -> choose Silence Alert -> Create Consequence: After Alert is changed to Silenced state, check Home -> Overview -> Status card and Notification Drawer, the silenced alert are still shown Fix: Updated Dashboard and Notification Drawer to not show Silenced Alerts Result: After Alert is changed to Silenced state, check Home -> Overview -> Status card and Notification Drawer, the silenced alert are not shown on page any more
Clone Of:
: 1808059 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:14:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4484 None closed [WIP] Bug 1802034: Silenced alerts should not show up in the Dashboards page of the console 2020-07-08 01:37:35 UTC
Github openshift console pull 4539 None closed Bug 1802034: Silenced alerts should not show up in the Dashboards page of the console [4.5] 2020-07-08 01:37:35 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:15:14 UTC

Description Lili Cosic 2020-02-12 08:53:01 UTC
Description of problem:
If I silence an alert I do not expect to see it anymore in the first page overview Dashboards page.

Version-Release number of selected component (if applicable):
4.3

How reproducible:

Always.

Steps to Reproduce:
Silence firing alert go to Dashboards page and see the alert is still there.

Comment 1 Yadan Pei 2020-04-07 09:50:00 UTC
1. Check Firing alerts in Home -> Overview -> Status card, firing alerts are shown
2. Check Firing alerts in Notification Drawer, firing alerts are shown
3. Silence an alert from Monitoring -> Alerts -> choose one firing alert -> click kebab -> choose Silence Alert -> Create
4. After Alert is changed to Silenced state, check Home -> Overview -> Status card and Notification Drawer, the silenced alert are not shown on page any more


Verified on 4.5.0-0.nightly-2020-04-06-184201

Comment 4 errata-xmlrpc 2020-07-13 17:14:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.