Bug 180209 - GNOME Screensaver allows ALT-F? keys
GNOME Screensaver allows ALT-F? keys
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-06 14:46 EST by Brian C. Huffman
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 12:59:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian C. Huffman 2006-02-06 14:46:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060202 Fedora/1.5.0.1-2 Firefox/1.5.0.1

Description of problem:
GNOME Screensaver allows ALT-F? keys.  So, you can switch to another virtual console without having to unlock the screensaver.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Lock screen
2. Hit ALT-F1
3.
  

Actual Results:  Goes to virtual console 1

Expected Results:  should stay locked and bring up password prompt

Additional info:
Comment 1 Matthias Clasen 2006-02-15 22:51:10 EST
I don't think the screensaver has a way to intercept Ctrl-Alt-F1, because
the X server acts on these key combinations before the client side ever 
sees them.

If you don't want that, you can set 

Option "DontVTSwitch" 

in your xorg.conf

Note You need to log in before you can comment on or make changes to this bug.