Bug 1802144 - Update the UI implementation of Snapshot to v1beta1 from alpha1 version
Summary: Update the UI implementation of Snapshot to v1beta1 from alpha1 version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ---
: 4.6.0
Assignee: Kanika Murarka
QA Contact: Jilju Joy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-12 13:05 UTC by Kanika Murarka
Modified: 2020-10-27 15:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 15:55:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
Snapshots listed in 'Volume Snapshots' page (117.71 KB, image/png)
2020-09-22 07:22 UTC, Jilju Joy
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4280 0 None closed Bug 1802144: Update Snapshot CR version same as backend 2020-09-21 09:14:11 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:55:31 UTC

Description Kanika Murarka 2020-02-12 13:05:09 UTC
Description of problem:
Snapshot feature was developed with Kubernates 1.16, which has alpha version of snapshot, as the backend is upgrading to 1.17 version kubenates which contain beta version of snapshot. UI needs changes for that.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
100%

Steps to Reproduce:
1.Go to PVC list page
2.Try to Create Snapshot, by seleting snasphot from Kebab
3.You will see error in creating it.

Actual results:
Snapshot is not created.

Expected results:
Snasphot should be created.

Additional info:

Comment 3 Oded 2020-05-17 13:48:37 UTC
No Sanpshot on OCP 4.4

Comment 4 Kanika Murarka 2020-05-18 05:36:37 UTC
Yes, the bug should be part of 4.6 as snapshot featuere is moved to 4.6.

Comment 6 Jilju Joy 2020-09-22 07:21:03 UTC
Verified this in version:


$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-09-22-000541   True        False         132m    Cluster version is 4.6.0-0.nightly-2020-09-22-000541

ocs-operator.v4.6.0-90.ci


Snapshot creations are successful.
apiVersion: snapshot.storage.k8s.io/v1beta1 is present in volume snapshot class, volume snapshot and volume snapshot content yamls.

Comment 7 Jilju Joy 2020-09-22 07:22:35 UTC
Created attachment 1715645 [details]
Snapshots listed in 'Volume Snapshots' page

Comment 9 errata-xmlrpc 2020-10-27 15:55:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.