Bug 1802161 - `regenerate-certificates` command blocked by error `illegal base64 data at input byte 3`
Summary: `regenerate-certificates` command blocked by error `illegal base64 data at in...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.3.z
Assignee: Lukasz Szaszkiewicz
QA Contact: Xingxing Xia
URL:
Whiteboard:
: 1789655 (view as bug list)
Depends On: 1785498
Blocks: 1789655
TreeView+ depends on / blocked
 
Reported: 2020-02-12 13:49 UTC by Lukasz Szaszkiewicz
Modified: 2020-05-27 17:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1785498
Environment:
Last Closed: 2020-05-27 17:00:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-kube-apiserver-operator pull 765 None closed Bug 1802161: `regenerate-certificates` command blocked by error `illegal base64 data at input byte 3` 2020-05-25 03:06:49 UTC
Red Hat Product Errata RHBA-2020:2184 None None None 2020-05-27 17:01:19 UTC

Comment 1 Michal Fojtik 2020-05-12 10:45:27 UTC
This bug hasn't had any activity in the last 30 days. Maybe the problem got resolved, was a duplicate of something else, or became less pressing for some reason - or maybe it's still relevant but just hasn't been looked at yet.

As such, we're marking this bug as "LifecycleStale" and decreasing the severity. 

If you have further information on the current state of the bug, please update it, otherwise this bug will be automatically closed in 7 days. The information can be, for example, that the problem still occurs, that you still want the feature, that more information is needed, or that the bug is (for whatever reason) no longer relevant.

Comment 2 Lukasz Szaszkiewicz 2020-05-12 12:59:03 UTC
*** Bug 1789655 has been marked as a duplicate of this bug. ***

Comment 6 Xingxing Xia 2020-05-20 10:38:58 UTC
Verified in 4.3.0-0.nightly-2020-05-18-121719 ipi aws etcd encrypted env by following the DR doc, the issue is gone.
Just found below after following the DR, will still investigate and file bug if any:
$ oc get co | grep -v "True.*False.*False"
NAME                                       VERSION                             AVAILABLE   PROGRESSING   DEGRADED   SINCE
authentication                             4.3.0-0.nightly-2020-05-18-121719   True        True          True       8h                  machine-config                             4.3.0-0.nightly-2020-05-18-121719   False       False         True       42m
monitoring                                 4.3.0-0.nightly-2020-05-18-121719   False       True          True       47m                 operator-lifecycle-manager-packageserver   4.3.0-0.nightly-2020-05-18-121719   False       True          False      56m

Comment 7 Xingxing Xia 2020-05-25 11:21:40 UTC
> $ oc get co | grep -v "True.*False.*False"
> NAME                                       VERSION                             AVAILABLE   PROGRESSING   DEGRADED   SINCE
> authentication                             4.3.0-0.nightly-2020-05-18-121719   True        True          True       8h
> machine-config                             4.3.0-0.nightly-2020-05-18-121719   False       False         True       42m
> monitoring                                 4.3.0-0.nightly-2020-05-18-121719   False       True          True       47m
> operator-lifecycle-manager-packageserver   4.3.0-0.nightly-2020-05-18-121719   False       True          False      56m

Today retried again in 4.3.0-0.nightly-2020-05-24-223407 IPI AWS etcd encrypted env. The DR succeeds, but this time didn't see abnormal operators like previous comment.

Comment 9 errata-xmlrpc 2020-05-27 17:00:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2184


Note You need to log in before you can comment on or make changes to this bug.