Bug 1802169 - tracker crashes with GLib-ERROR: Failed to set scheduler settings
Summary: tracker crashes with GLib-ERROR: Failed to set scheduler settings
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: tracker
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Debarshi Ray
QA Contact: Fedora Extras Quality Assurance
URL: https://gitlab.gnome.org/GNOME/tracke...
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F32FinalBlocker, FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-02-12 14:03 UTC by Jonathan Haas
Modified: 2020-03-15 19:10 UTC (History)
9 users (show)

Fixed In Version: tracker-miners-2.3.2-2.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-15 19:10:52 UTC
Type: Bug


Attachments (Terms of Use)

Description Jonathan Haas 2020-02-12 14:03:24 UTC
Description of problem:

Tracker always crashes after login to Gnome Desktop, showing multiple crash notifications. The backtrace generated by abrt isn't usable, but manually debugging reveals this:

[jh@localhost ~]$ lang=C gdb /usr/libexec/tracker-extract 
GNU gdb (GDB) Fedora 9.1-1.fc32

(gdb) run
Starting program: /usr/libexec/tracker-extract 
   

[New Thread 0x7fffe7103700 (LWP 37230)]
[New Thread 0x7fffe68d6700 (LWP 37231)]
[New Thread 0x7fffe606c700 (LWP 37232)]
[New Thread 0x7fffe586b700 (LWP 37233)]
[New Thread 0x7fffe506a700 (LWP 37234)]
[New Thread 0x7fffe4869700 (LWP 37235)]
[New Thread 0x7fffcffff700 (LWP 37236)]
[New Thread 0x7fffcf7fe700 (LWP 37237)]
[New Thread 0x7fffceffd700 (LWP 37238)]
[New Thread 0x7fffce7fc700 (LWP 37239)]
[New Thread 0x7fffcdffb700 (LWP 37240)]
[New Thread 0x7fffcd7fa700 (LWP 37241)]
[New Thread 0x7fffccff9700 (LWP 37242)]
[New Thread 0x7fffaef2e700 (LWP 37243)]
[New Thread 0x7fffae6aa700 (LWP 37244)]

(tracker-extract:37226): GLib-ERROR **: 14:55:40.216: Failed to set scheduler settings: Die Operation ist nicht erlaubt (=> the operation is not allowed)

Thread 16 "tracker-extract" received signal SIGTRAP, Trace/breakpoint trap.
[Switching to Thread 0x7fffae6aa700 (LWP 37244)]
0x00007ffff7c2b977 in g_log_structured_array () from /usr/lib64/libglib-2.0.so.0

(gdb) bt
#0  0x00007ffff7c2b977 in g_log_structured_array () from /usr/lib64/libglib-2.0.so.0
#1  0x00007ffff7c2bd89 in g_log_default_handler () from /usr/lib64/libglib-2.0.so.0
#2  0x00007ffff7c2bfd9 in g_logv () from /usr/lib64/libglib-2.0.so.0
#3  0x00007ffff7c2c273 in g_log () from /usr/lib64/libglib-2.0.so.0
#4  0x00007ffff7c7261b in linux_pthread_proxy () from /usr/lib64/libglib-2.0.so.0
#5  0x00007ffff7b20432 in start_thread () from /usr/lib64/libpthread.so.0
#6  0x00007ffff7a4e833 in clone () from /usr/lib64/libc.so.6


Version-Release number of selected component (if applicable): 2.3.1-3.fc32.x86_64

How reproducible: Always

Additional info:

Probably related to this change: https://gitlab.gnome.org/GNOME/glib/commit/e18cc872b8d6b744605c5dd3cd36dd1144a97318

Running with enforcing=0, so not a SELinux issue.

Comment 1 Fedora Blocker Bugs Application 2020-02-12 14:07:00 UTC
Proposed as a Blocker for 32-final by Fedora user jonha using the blocker tracking app because:

 There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop.

Comment 2 Geoffrey Marr 2020-02-17 19:38:24 UTC
Discussed during the 2020-02-17 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker" was made as it violates the following criterion:

"There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop".

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-02-17/f32-blocker-review.2020-02-17-17.02.txt

Comment 3 Kalev Lember 2020-02-19 18:39:41 UTC
Hopefully fixed in tracker-miners-2.3.2-2.fc32 (I've backported https://gitlab.gnome.org/GNOME/tracker-miners/merge_requests/148 to it; thanks to cgarnacho for investigating and coming up with a fix!)

Comment 4 Jonathan Haas 2020-03-15 09:24:29 UTC
I can confirm that the problem is fixed in latest F32 Beta (tracker-miners-2.3.3-1.fc32.x86_64)

Comment 5 Michael Catanzaro 2020-03-15 19:10:52 UTC
(In reply to Jonathan Haas from comment #4)
> I can confirm that the problem is fixed in latest F32 Beta
> (tracker-miners-2.3.3-1.fc32.x86_64)

This package made it to stable.


Note You need to log in before you can comment on or make changes to this bug.