Bug 1802230 - Services are not displayed on VM and VMI Details page
Summary: Services are not displayed on VM and VMI Details page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Yaacov Zamir
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-12 16:23 UTC by Radim Hrazdil
Modified: 2020-05-13 21:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:57:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4299 0 None closed Bug 1802230: Fix missing services in VM details page 2020-04-30 08:37:15 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:57:51 UTC

Description Radim Hrazdil 2020-02-12 16:23:46 UTC
Description of problem:
Exposed services are not displayed on VM and VMI Details page.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
100%

Steps to Reproduce:
1. Create a VM/VMI
2. Expose a service:
$ virtctl expose vm <vm_name> --port=22 --target-port=20022 --name=test-ssh --type=NodePort
3.

Actual results:


Expected results:


Additional info:

Comment 1 Yaacov Zamir 2020-02-12 17:37:38 UTC
Submitted upstream:
https://github.com/openshift/console/pull/4299

Comment 4 Guohua Ouyang 2020-02-19 02:41:02 UTC
failed on 4.4.0-0.nightly-2020-02-10-111955.

Comment 5 Yaacov Zamir 2020-02-19 08:46:52 UTC
Guohua Ouyang Hi,

The fixed was merged upstream on 2020-02-13 https://bugzilla.redhat.com/show_bug.cgi?id=1802230#c1

failed on 4.4.0-0.nightly-2020-02-10-111955.

Can you verify on a version created from upstream after 2020-02-13 ?

Comment 7 Guohua Ouyang 2020-02-20 02:37:18 UTC
verified on 4.4.0-0.nightly-2020-02-17-022408

Comment 8 Yaacov Zamir 2020-04-30 08:38:46 UTC
docs stay the same after bug fix

Comment 10 errata-xmlrpc 2020-05-13 21:57:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.