Bug 1802308 - Resources tab of helm release details page doesn't work for Helm 3 charts
Summary: Resources tab of helm release details page doesn't work for Helm 3 charts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Rohit Rai
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-12 20:59 UTC by Rohit Rai
Modified: 2020-05-13 21:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:57:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
resources tab for helm charts (54.42 KB, image/jpeg)
2020-03-04 12:41 UTC, Gajanan More
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4302 None closed Bug 1802308: Fetch Helm resources based on manifest in release data 2020-10-06 10:49:42 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:57:57 UTC

Description Rohit Rai 2020-02-12 20:59:27 UTC
Description of problem:
Helm 3 charts do not have proper labels set which is being used to identify the resources in resources tab of helm release details page. This is why older Helm 2 charts work fine but resources created by newer charts do not show up under the resources tab of helm release details page.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install `nodejs-ex-chart` from helm catalog
2. go to helm release details page
3. click on resources tab. it shows only one resource.

Actual results:
The resources tab show only 1 resource

Expected results:
The resources tab should show all the resources created by helm release.

Additional info:

Comment 3 Gajanan More 2020-03-04 12:41:53 UTC
Created attachment 1667482 [details]
resources tab for helm charts

Comment 4 Gajanan More 2020-03-04 12:42:55 UTC
I have validated this bug on 
Build:4.4.0-0.nightly-2020-03-04-000622 
Browser:Google Chrome Version 78.0.3904.108
Marking this bug as verified

Comment 6 errata-xmlrpc 2020-05-13 21:57:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.