Bug 1802392 - lyx 2.3.4 under Wayland has a quirky UI drop-down menu positioning defect.
Summary: lyx 2.3.4 under Wayland has a quirky UI drop-down menu positioning defect.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lyx
Version: 31
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1822499 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-13 03:57 UTC by Bruce Bigby
Modified: 2020-06-13 17:22 UTC (History)
3 users (show)

Fixed In Version: lyx-2.3.5-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-11 22:56:58 UTC
Type: Bug


Attachments (Terms of Use)

Description Bruce Bigby 2020-02-13 03:57:41 UTC
Description of problem:

When I open the Lyx 2.3.4 application under Wayland, click on the "File" drop-down menu, click on "Exit", and repeat all of the previous steps 3 additional times, the drop-down menu will eventually begin to drift downward such that an ever-increasing gap appears between the words, "File" and "New".


Version-Release number of selected component (if applicable): 2.3.4


How reproducible:


Steps to Reproduce:
1. Open Lyx.
2. Click on the top-bar menu option, "File".
3. Click on "Exit".
4. Repeat steps 1 through 3, two more times, but each time after clicking on "File", but before clicking on "Exit", notice that there is NO gap between the word, "File", and the word, "New".
5. Now, repeat steps 1 through 3 one more time, but before clicking on Exit, notice that a gap appears between the word, "File", and the word, "New". You might need to repeat a few more times to see the defect.
6. Now, repeat steps 1 through 3 continually, and each time before clicking "Exit", notice how the gap between the words, "File" and "New", continues to grow, making the menu appear to drift downward.


Actual results:

"File" drop-down menu drifts downward.

Expected results:

"File" drop-down menu should remain directly underneath the "File" menu regardless of the number of times a user opens the application and exits.

Additional info:

The way I can reset the issue is by forcing Lyx to run as an X application -- for example,

ssh -X localhost lyx

When I check the drop-down menu for the "File" option, the position is normal. Then, I exit.

Now, I run lyx normally in Wayland mode either from the icon launcher or at the terminal as the following:

lyx

and the drop-down menu for the "File" option is back to its normal position. However, if I repeat the steps above to reproduce the problem, eventually the menu will start drifting downward.  By the way, the problem applies to all drop-down menus -- not just the "File" drop-down menu.

There appears to be some persistent menu positioning state information that persists and is NOT reinitialized properly across instantiations of lyx processes. Developers should also consider behavior when a user launches multiple instances of lyx that run concurrently.  The positions of all drop-down menus should be correct -- in other words, not drift.

Comment 1 José Matos 2020-02-14 18:51:28 UTC
What you describe happens on the primary display.

On the secondary display the drop-down menu only shows the first time. The next times you press it does not appear. Moving the window to the primary display shows the effect you reported.

Comment 2 Bruce Bigby 2020-02-19 01:32:43 UTC
(In reply to José Matos from comment #1)
> What you describe happens on the primary display.
> 
> On the secondary display the drop-down menu only shows the first time. The
> next times you press it does not appear. Moving the window to the primary
> display shows the effect you reported.

Yes. I concur. I am seeing what you have described on the secondary display.

Comment 3 Rex Dieter 2020-04-09 15:10:36 UTC
*** Bug 1822499 has been marked as a duplicate of this bug. ***

Comment 4 carlosjosepita 2020-04-20 05:56:42 UTC
I've reported this upstream in: https://www.lyx.org/trac/ticket/11847.

Also, a related Gnome Shell report: https://gitlab.gnome.org/GNOME/gnome-shell/issues/1779.

Comment 5 Rex Dieter 2020-04-20 19:17:11 UTC
This is most likely not a gnome shell issue.

Related,
https://fedoraproject.org/wiki/Changes/Qt_Wayland_By_Default_On_Gnome

Possible for problematic Qt clients to be patched to not use wayland (we may want to do that here)

Comment 6 carlosjosepita 2020-04-20 21:24:21 UTC
Short of patching, you can always do `QT_QPA_PLATFORM=xcb lyx`.

Comment 7 Bruce Bigby 2020-04-21 02:41:52 UTC
(In reply to carlosjosepita from comment #6)
> Short of patching, you can always do `QT_QPA_PLATFORM=xcb lyx`.

I was hoping for a simple effective workaround like this. Thanks.

Comment 8 Bruce Bigby 2020-04-21 02:45:35 UTC
By the way, I created a script using the information from Comment 6.

################################
#!/bin/bash

QT_QPA_PLATFORM=xcb /usr/bin/lyx
################################

and placed it in $HOME/bin/lyx. Note: My $HOME/bin precedes /usr/bin in my $PATH.  I'm running Fedora 31.

Comment 9 Bruce Bigby 2020-04-25 18:24:37 UTC
(In reply to carlosjosepita from comment #6)
> Short of patching, you can always do `QT_QPA_PLATFORM=xcb lyx`.

Correction to the script that I created.  One needs to pass $* to your command as in the following, below:

By the way, I created a script using the information from Comment 6.

################################
#!/bin/bash

QT_QPA_PLATFORM=xcb /usr/bin/lyx $*
################################

and placed it in $HOME/bin/lyx. Note: My $HOME/bin precedes /usr/bin in my $PATH.  I'm running Fedora 31.

Comment 10 Fedora Update System 2020-06-03 07:34:02 UTC
FEDORA-2020-684cee3845 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-684cee3845

Comment 11 Fedora Update System 2020-06-04 04:08:18 UTC
FEDORA-2020-684cee3845 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-684cee3845`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-684cee3845

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2020-06-11 22:56:58 UTC
lyx-2.3.5-1.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Bruce Bigby 2020-06-12 01:26:01 UTC
I'm seeing menu issues still when closing lyx and reopening it at least 4 times in succession. The menus detach and begin to drift down away from the top menu bar with each successive application reopening.  This issue happens under Wayland.  However, if I run the application like this,

QT_QPA_PLATFORM=xcb /usr/bin/lyx <args>

I do not see any issues.

Comment 14 Bruce Bigby 2020-06-12 17:42:19 UTC
Note that the problem occurs on my secondary monitor at least.  I haven't tried it on my primary monitor yet.

Comment 15 José Matos 2020-06-13 17:22:08 UTC
I decide to open gnome and I am not seeing this anymore, be it in the primary or secondary displays.

FWIW I am running with updates-testing enable and I suspect, although I could be wrong - naturally, that the culprit, to solve the issue, is using qt-5.14 and not the update to lyx 2.3.5.


Note You need to log in before you can comment on or make changes to this bug.