Bug 1802399 - Independent Mode does not show option to export cluster metadata in the kebab menu
Summary: Independent Mode does not show option to export cluster metadata in the kebab...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Bipul Adhikari
QA Contact: Oded
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-13 04:36 UTC by Bipul Adhikari
Modified: 2020-07-13 17:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:14:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
Cluster Metadata (100.18 KB, image/png)
2020-05-15 11:07 UTC, Oded
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4222 None closed Bug 1802399: Added export cluster metadata in storage cluster menu 2020-06-23 08:28:38 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:15:14 UTC

Description Bipul Adhikari 2020-02-13 04:36:46 UTC
Description of problem:
Storage Cluster does not have an option to export cluster metadata in the kebab menu.


Version-Release number of selected component (if applicable):
4.4

How reproducible:
1/1

Steps to Reproduce:
1. Create a storage cluster.
2. Go to either the details/list page for Storage Cluster in OCS(Inside Installed Operators)
3. No support for Exporting Metadata.

Actual results:
No option to export metadata.

Expected results:
Should have an option.

Comment 4 Oded 2020-05-15 11:06:56 UTC
Bug not reconstructed

Setup:
Provider-vmware
OCP Version- 4.4.0-0.nightly-2020-05-07-045837
OCS Version-4.3


Steps to Reproduce:
1.Go to Installed Operators -> OCS -> Storage Cluster 
2.Download Cluster MetaData 
*attached screenshot
3.Output:
credentials.json
{"admin":"AQDl6LNeM8AqLxAAdRmqlqZK+z8XXi7e9ecE+w==","monData":"a=172.30.138.93:6789","clusterName":"openshift-storage","fsid":"646e318f-5726-4855-b0bd-cdd08ccbe3fd"}

Comment 5 Oded 2020-05-15 11:07:55 UTC
Created attachment 1688891 [details]
Cluster Metadata

Comment 6 Oded 2020-05-19 11:26:43 UTC
Is it proper to verify this bug with OCP 4.4 and OCS 4.3?

Comment 7 Bipul Adhikari 2020-05-19 14:39:13 UTC
Only in 4.5 and above can this be tested.

Comment 10 Oded 2020-05-24 18:03:46 UTC
Bug Not Reconstructed 
Setup:
Provider:AWS
OCP Version:4.5.0-0.nightly-2020-05-24-072501
OCS Version:ocs-operator.v4.5.0-433.ci

Test Process:
1.Go to Installed Operators -> OCS -> Storage Cluster 
2.Download Cluster MetaData 
3.Output:
credentials.json
{"admin":"AQCmX8pebJsJGBAAYT4U41h0KcpQDS4l4s291Q==","monData":"b=172.30.206.47:6789","clusterName":"openshift-storage","fsid":"bf9cdc97-8173-46c1-bd29-ecc80cd09147"}

Comment 13 errata-xmlrpc 2020-07-13 17:14:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.