Bug 1802431 - Label text box has grey text "Add=Frontend" that does not disappear when copy pasting content into the box
Summary: Label text box has grey text "Add=Frontend" that does not disappear when copy...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-13 06:16 UTC by Olive Lakra
Modified: 2020-05-04 11:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:36:23 UTC
Target Upstream Version:


Attachments (Terms of Use)
Create Namespace dialog box (20.78 KB, image/png)
2020-02-13 06:16 UTC, Olive Lakra
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4310 None closed Bug 1802431: Remove label input placeholder if any labels are present 2020-09-04 13:17:53 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:36:42 UTC

Description Olive Lakra 2020-02-13 06:16:13 UTC
Created attachment 1662878 [details]
Create Namespace dialog box

Description of problem
On OCP web console -> Administration -> Namespaces -> Create Namespace, in the Create Namespace dialog box, while entering "openshift-storage" for Name and "openshift.io/cluster-monitoring=true" for Labels, the grey text "Add=Frontend" in Labels text box, does not disappear when copy pasting content into the box.

Also the text "Add=Frontent" is confusing as it does not provide clear information on what the labels text box is for and what kind of information a user needs to provide here.


Version-Release number of selected component (if applicable): 4.3


How reproducible:
When creating a namespace using the OCS 4.2 deployment instructions on section 1.1.1 Prerequisites
https://access.redhat.com/documentation/en-us/red_hat_openshift_container_storage/4.2/html-single/deploying_openshift_container_storage/index


Steps to Reproduce:
1. On OCP web console -> Administration -> Namespaces -> click Create Namespace
2. In the Create Namespace dialog box, enter "openshift-storage" for Name and "openshift.io/cluster-monitoring=true" for Labels.

Actual results: 
The grey text "Add=Frontend" disappears the moment you start typing the text "openshift.io/cluster-monitoring=true" for Labels but when you copy paste this text from the guide then "Add=Frontend" does not disappear and also you will not be able to delete this text.


Expected results: 
"Add=Frontend" should disappear irrespective of the action being performed in the labels text box (typing or copy-paste action)


Additional info:

Comment 3 Yanping Zhang 2020-02-14 06:52:42 UTC
Checked on ocp 4.4 with payload 4.4.0-0.nightly-2020-02-13-212616, create namespace, after input name, type or copy a label to the label input box, the "app=frontend" will disappear.
The bug is fixed, so move it to Verified.

Comment 5 errata-xmlrpc 2020-05-04 11:36:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.