Bug 1802452 - [virtio-win][vioscsi] WMI facility check virito-scsi num_queues failed
Summary: [virtio-win][vioscsi] WMI facility check virito-scsi num_queues failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: virtio-win
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: Vadim Rozenfeld
QA Contact: Peixiu Hou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-13 07:21 UTC by Peixiu Hou
Modified: 2020-04-28 16:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:05:21 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
vioscsi.vbs scripts (1.48 KB, text/plain)
2020-02-13 07:21 UTC, Peixiu Hou
no flags Details
updated VB script. Should be used with build 180 (1.55 KB, text/plain)
2020-02-19 11:55 UTC, Vadim Rozenfeld
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:1757 None None None 2020-04-28 16:05:22 UTC

Description Peixiu Hou 2020-02-13 07:21:44 UTC
Created attachment 1662896 [details]
vioscsi.vbs scripts

Description of problem:
run a case "WMI facility to check the virito-scsi mq enabled" failed as none num_queues info collected on vioscsi.log file after run vioscsi.vbs scripts.

Version-Release number of selected component (if applicable):
kernel-4.18.0-175.el8.x86_64
qemu-kvm-4.2.0-8.module+el8.2.0+5607+dc756904.x86_64
seabios-1.13.0-1.module+el8.2.0+5520+4e5817f3.x86_64
edk2-ovmf-20190829git37eef91017ad-4.el8.noarch
virtio-win-prewhql-178

How reproducible:
100%

Steps to Reproduce:
1.  Booted a guest vm up with num_queues=4 for virtio-scsi-pci.
==================================================================
    -machine q35  \
    -smp 4,maxcpus=4,cores=2,threads=1,dies=1,sockets=2  \
    -cpu 'Skylake-Server',hv_stimer,hv_synic,hv_vpindex,hv_reset,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic,hv_time,hv-tlbflush,+kvm_pv_unhalt  \
    -device pcie-root-port,id=pcie.0-root-port-3,slot=3,chassis=3,addr=0x3,bus=pcie.0 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,num_queues=4,bus=pcie.0-root-port-3,addr=0x0 \
    -blockdev node-name=file_image1,driver=file,aio=threads,filename=/home/kvm_autotest_root/images/win2012-64-virtio-scsi.qcow2,cache.direct=on,cache.no-flush=off \
    -blockdev node-name=drive_image1,driver=qcow2,cache.direct=on,cache.no-flush=off,file=file_image1 \
    -device scsi-hd,id=image1,drive=drive_image1,write-cache=on \
=========================================================== ======
2. run vioscsi.vbs scripts with Administrator privileges.
3. Check the generated vioscsi.log file.  --> none instance info collected, only show one line in vioscsi.log file as follows:
==================================================================

VioScsiExtendedInfoGuid

4. Downgrade the vioscsi driver to virtio-win-1.9.10-3.el8.iso(vioscsi build 160), repeat step2-step3, checked the vioscsi.log, the instance info shown normally, details as follows:
==================================================================
VioScsiExtendedInfoGuid
    InstanceName=PCI\VEN_1AF4&DEV_1048&SUBSYS_11001AF4&REV_01\4&785f959&0&000A_0
        instance.QueueDepth=128
        instance.QueuesCount=4
        instance.Indirect=True
        instance.EventIndex=True
        instance.DpcRedirection=True
        instance.InterruptMsgRanges=True
        instance.CompletionDuringStartIo=False
==================================================================

Actual results:
none scsi info collected in vioscsi.log

Expected results:
scsi info show normally

Additional info:
Tested with virtio-win-1.9.10-3.el8(vioscsi build 160), cannot reproduce this issue, so it's a regression issue.

Comment 1 Peixiu Hou 2020-02-14 03:56:13 UTC
Hi vadim,

Tried tested with virtio-win-prewhql-173 and virtio-win-prewhql-175, both cannot reproduce this issue~
Tried tested with virtio-win-prewhql-179, also reproduced this issue.
Hope this information is useful~

Best Regards~
Peixiu

Comment 2 Vadim Rozenfeld 2020-02-19 11:55:44 UTC
Created attachment 1664015 [details]
updated  VB script. Should be used with build 180

Comment 3 Vadim Rozenfeld 2020-02-19 11:57:01 UTC
Please give a try to build 180
https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=1094583

Vadim.

Comment 4 Peixiu Hou 2020-02-19 14:16:52 UTC
(In reply to Vadim Rozenfeld from comment #3)
> Please give a try to build 180
> https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=1094583
> 
> Vadim.

Tested with build 180, cannot reproduce this issue, the correct vioscsi.log can be generated, and the queues info is correct.

VioScsiExtendedInfoGuid
    InstanceName=PCI\VEN_1AF4&DEV_1048&SUBSYS_11001AF4&REV_01\4&785f959&0&000A_0
        instance.QueueDepth=128
        instance.QueuesCount=4
        instance.Indirect=True
        instance.EventIndex=True
        instance.DpcRedirection=True
        instance.InterruptMsgRanges=True
        instance.CompletionDuringStartIo=False

Change this issue to verified.

Thanks a lot~
Peixiu

Comment 10 errata-xmlrpc 2020-04-28 16:05:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:1757


Note You need to log in before you can comment on or make changes to this bug.