Bug 1802638 - [IPV6] The metering-operator cannot create an s3 bucket using the "s3_bucket" module
Summary: [IPV6] The metering-operator cannot create an s3 bucket using the "s3_bucket"...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Metering Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.4.0
Assignee: tflannag
QA Contact: Peter Ruan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-13 15:21 UTC by tflannag
Modified: 2020-05-04 11:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:36:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-metering pull 1101 0 None closed Bug 1802638: Allow support for creating an S3 bucket on an IPV6 cluster. 2020-04-27 14:36:09 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:36:39 UTC

Description tflannag 2020-02-13 15:21:42 UTC
Description of problem:
When attempting to use `createBucket: true` and specifying a bucket name and region, the `s3_bucket` module cannot connect to the default s3.<region>.amazonaws.com endpoint. When you try to update the module to use the dualstack endpoint (s3.dualstack.<region>.amazonaws.com) via the s3_url option, it still uses the same endpoint and therefore fails role execution:

```
Thursday 13 February 2020  15:18:03 +0000 (0:00:00.326)       0:00:13.742 ***** 
[DEPRECATION WARNING]: evaluating s3_credentials_secret_exists as a bare 
variable, this behaviour will go away and you might need to add |bool to the 
expression in the future. Also see CONDITIONAL_BARE_VARS configuration toggle..
 This feature will be removed in version 2.12. Deprecation warnings can be 
disabled by setting deprecation_warnings=False in ansible.cfg.
 [WARNING]: conditional statements should not include jinja2 templating
delimiters such as {{ }} or {% %}. Found: {{
operator_s3_credentials_secret.resources and
operator_s3_credentials_secret.resources | length > 0 }}

An exception occurred during task execution. To see the full traceback, use -vvv. The error was: EndpointConnectionError: Could not connect to the endpoint URL: "https://s3.us-west-1.amazonaws.com/"
fatal: [localhost]: FAILED! => {"boto3_version": "1.11.15", "botocore_version": "1.14.15", "changed": false, "msg": "Invalid endpoint provided: Could not connect to the endpoint URL: \"https://s3.us-west-1.amazonaws.com/\": Could not connect to the endpoint URL: \"https://s3.us-west-1.amazonaws.com/\""}
```

Version-Release number of selected component (if applicable):
4.4/4.3

How reproducible:
Always

Steps to Reproduce:
1. Install Metering using s3 for storage and `createBucket: true` in the MeteringConfig CR
2. Wait ~60s for the metering-operator to get to the storage-related tasks in the role
3. View the ansible container logs of the metering-operator pod

Actual results:


Expected results:


Additional info:

Comment 5 Peter Ruan 2020-03-13 07:06:32 UTC
verified with a meteringconfig that uses a s3 bucket and able to create a report successfully

pruan@MacBook-Pro ~/workspace/gocode/src/github.com/operator-framework/operator-metering (master●)$ oc get pods
NAME                                  READY   STATUS    RESTARTS   AGE
hive-metastore-0                      2/2     Running   0          3m17s
hive-server-0                         3/3     Running   0          3m17s
metering-operator-7b96748b96-96njb    2/2     Running   0          5m54s
presto-coordinator-0                  2/2     Running   0          2m43s
reporting-operator-6fc7fc5c4c-nl2pl   2/2     Running   0          2m8s

pruan@MacBook-Pro ~/workspace/v3-testfiles/metering/rollup_reports (master●)$ oc get reports
NAME                              QUERY                         SCHEDULE   RUNNING    FAILED   LAST REPORT TIME       AGE
persistentvolumeclaim-usage-now   persistentvolumeclaim-usage              Finished            2020-12-30T23:59:59Z   7s

Comment 7 errata-xmlrpc 2020-05-04 11:36:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.