Bug 180269 - error on edit properies of snapshotted mirror
error on edit properies of snapshotted mirror
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-lvm (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-06 15:55 EST by Nate Straz
Modified: 2009-04-16 19:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-30 10:51:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nate Straz 2006-02-06 15:55:43 EST
Description of problem:
An improper error message pops up when I try to edit properties of a mirror LV
that I have created a snapshot of.

Version-Release number of selected component (if applicable):
system-config-lvm-1.0.9-1.0

How reproducible:
every time

Steps to Reproduce:
1. Create a mirror volume
2. Create a snapshot of the mirror volume
3. Select the mirror volume
4. Click the "Edit Properties" button

Actual results:

A dialog with the error message "Logical Volumes with associated snapshots
cannot be mirrored yet."

After clearing the error dialog, the edit form shows the LV is not mirrored
which conflicts with the properties window.
  
Expected results:

The Edit Properties form should appear with the mirror box checked.
Additional info:
Comment 1 Stanko Kupcevic 2006-02-14 17:05:10 EST
Fixed in 1.0.14
Comment 4 Nate Straz 2006-07-05 18:14:28 EDT
When I try this now I get this message from lvcreate:

  Snapshots and mirrors may not yet be mixed.

This bz should probably be deferred until that time.
Comment 5 Stanko Kupcevic 2006-07-10 12:35:47 EDT
Defering until LVM supports snapshots of mirrors...

For now, trying to create a snapshot of a mirror will fail with a a message "A
snapshot of a mirrored Logical Volume is not supported."
Comment 9 Jim Parsons 2006-09-06 11:17:56 EDT
It should be noted, that this UI feature depends on underlying support for
snapshots of mirrored volumes. The UI capability is easy to turn on - it has
already been implemented and commented out - see above! :)
Comment 10 Jim Parsons 2007-01-30 10:51:43 EST
Because snapshots of mirrored volumes is not yet supported, the capability to do
this task will remain commented out in the UI code for this next 4.5 release. 
Deferring until 4.6

Note You need to log in before you can comment on or make changes to this bug.