Bug 18027 - cpp is broken in RH7
cpp is broken in RH7
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-01 13:36 EDT by Paul Johnson
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-06 07:17:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Johnson 2000-10-01 13:36:13 EDT
The gcc in RH7 won't process files that use this macro:
#define raiseEvent( eventType, formatString, args... ) [eventType
raiseEvent: "\r" __FUNCTION__, __FILE__, __LINE__, formatString , ##
args]

Which gets used in this way:

if (![self _lispInAttr_: index])
            raiseEvent (InvalidArgument, "unknown keyword `%s'",
name);

The error says "pasting would not give a valid preprocessing token"
 
I've confirmed that gcc-2.95.2 processes this correctly and cpp from the
current gcc CVS tree fixes that.
Comment 1 Michael McTernan 2000-10-01 14:39:00 EDT
Hi,

I find that compiling the kernel 2.2.17 (from kernel.org) produces numerous 
occurences of this error (pasting would not give a valid preprocessing token) 
also, before failing compilation at Checksun.S

Mike
Comment 2 Jakub Jelinek 2000-10-03 04:40:39 EDT
Actually, it is not an error, it is a warning and in this case bogus.
It has been fixed since then and will appear in the next gcc errata
(after a few more issues are solved especially on Alpha).

Concerning kernel compilation, RELEASE-NOTES mention that you should not
compile 2.2.x kernels with this gcc, use make CC='kgcc -D__KERNEL__ -I$(HPATH)'
instead, the checksum.S failure is because 2.2 kernels use -traditional
and GNU macro extensions at the same time (fixed in 2.4 kernels), many of the
pasting warnings are bugs in 2.2 kernels and not bugs in cpp.
Comment 3 Need Real Name 2000-10-06 07:17:27 EDT
Hello.

     I have also seen this problem in a big way, I can not compile almost every 
program and kernel I have tried, even the beta 2.4 kernels!!  this is very 
serious for me as the standard kernel is not suitable for my machine (it is 
just good enough to boot it to build a better one)

Jesse Brain

(jessebrain@ozemail.com.au)
Comment 4 Jakub Jelinek 2000-10-24 04:22:02 EDT
Should be fixed in gcc-2.96-60 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.