Bug 1802936 - The 'vfRange' in NodeState is incorrect when 'pfName' is not specified in node policy CR
Summary: The 'vfRange' in NodeState is incorrect when 'pfName' is not specified in nod...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: Peng Liu
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On:
Blocks: 1804986
TreeView+ depends on / blocked
 
Reported: 2020-02-14 07:16 UTC by Peng Liu
Modified: 2020-05-04 11:37 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1804986 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:36:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift sriov-network-operator pull 152 0 None closed Bug 1802936: Set default vfRange when pfName is not specified in policy 2020-02-24 08:06:21 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:37:46 UTC

Description Peng Liu 2020-02-14 07:16:03 UTC
Description of problem:
The 'vfRange' in NodeState is incorrect when 'pfName' is not specified in node policy CR.
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. launch the operator, and apply the following node policy.
```
apiVersion: sriovnetwork.openshift.io/v1
kind: SriovNetworkNodePolicy
metadata:
  name: policy-net-2
spec:
  resourceName: nic2
  nodeSelector:
    feature.node.kubernetes.io/network-sriov.capable: "true"
  priority: 99
  mtu: 9000
  numVfs: 4
  nicSelector:
    vendor: "8086"
    rootDevices: ['0000:86:00.1']
```

2. Check the node state of the worker node.
```
apiVersion: sriovnetwork.openshift.io/v1
kind: SriovNetworkNodeState
metadata:
...
  name: nfvpe-25.oot.lab.eng.bos.redhat.com
  namespace: openshift-sriov-network-operator
...
spec:
  dpConfigVersion: "4454192"
  interfaces:
  - mtu: 9000
    name: ens803f1
    numVfs: 4
    pciAddress: 0000:86:00.1
    vfGroups:
    - deviceType: netdevice
      resourceName: nic2
      vfRange: 0-0
```

3.

Actual results:

The 'vfRange' was '0-0'.

Expected results:

The 'vfRange' should be '0-3'.

Additional info:

Comment 3 zhaozhanqi 2020-02-25 07:08:20 UTC
Verified this bug see steps with https://bugzilla.redhat.com/show_bug.cgi?id=1804986#c4

Comment 5 errata-xmlrpc 2020-05-04 11:36:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.