Bug 1803084 - openshift-apiserver 4.2: Unbounded valuesets for metric labels
Summary: openshift-apiserver 4.2: Unbounded valuesets for metric labels
Keywords:
Status: CLOSED DUPLICATE of bug 1798297
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-apiserver
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.z
Assignee: Stefan Schimanski
QA Contact: Ke Wang
URL:
Whiteboard:
Depends On: 1803080
Blocks: 1798291 1798297
TreeView+ depends on / blocked
 
Reported: 2020-02-14 12:48 UTC by Stefan Schimanski
Modified: 2020-05-27 10:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1803080
: 1803087 (view as bug list)
Environment:
Last Closed: 2020-05-27 10:11:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift openshift-apiserver pull 76 None closed Bug 1803084: 4.2: UPSTREAM: 87673: blank out value for unbounded client label 2020-06-10 15:37:49 UTC

Comment 7 Ke Wang 2020-05-26 02:35:48 UTC
Checked related metrics from Prometheus  for 4.2 not fixed OCP build, client tag is not empty, see the following
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.2.0-0.nightly-2020-04-12-022832   True        False         24m     Cluster version is 4.2.0-0.nightly-2020-04-12-022832

apiserver_request_total{client="cluster-kube-apiserver-operator/v0.0.0 (linux/amd64) kubernetes/$Format",code="0",component="apiserver",contentType="application/json",endpoint="https",group="config.openshift.io",instance="...:6443",job="apiserver",namespace="default",resource="apiservers",scope="cluster",service="kubernetes",verb="WATCH",version="v1"}

Verified with fixed OCP build 4.2.0-0.nightly-2020-05-07-194422,  searched related metrics from Prometheus

apiserver_request_count{code="200",component="apiserver",contentType="application/vnd.kubernetes.protobuf",endpoint="https",group="oauth.openshift.io",instance="...:8443",job="api",namespace="openshift-apiserver",pod="apiserver-lf9qz",resource="oauthclients",scope="cluster",service="api",verb="GET",version="v1"}

apiserver_request_total{code="200",component="apiserver",contentType="application/json",endpoint="https",group="image.openshift.io",instance="...42:8443",job="api",namespace="openshift-apiserver",pod="apiserver-f9qp8",resource="imagestreams",scope="cluster",service="api",verb="LIST",version="v1"}

Compared old 4.2 and latest 4.2 build about the apiserver_request_total and  apiserver_request_count at the Prometheus metric, the label ‘client’ was gone, it is as expected.

Comment 8 Xingxing Xia 2020-05-27 10:11:13 UTC
Per https://bugzilla.redhat.com/show_bug.cgi?id=1798297#c6, closing this bug 1803084 as dup to avoid the same issue is dup tracked and verified in multiple bugs.

*** This bug has been marked as a duplicate of bug 1798297 ***


Note You need to log in before you can comment on or make changes to this bug.