Bug 1803089 - Edit Disk Dialog in Wizard doesn't display interface as Not Recommended when it's selected
Summary: Edit Disk Dialog in Wizard doesn't display interface as Not Recommended when ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: Ido Rosenzwig
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks: 1808296
TreeView+ depends on / blocked
 
Reported: 2020-02-14 12:55 UTC by Radim Hrazdil
Modified: 2020-05-04 11:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1808296 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:36:41 UTC
Target Upstream Version:


Attachments (Terms of Use)
Virtio selected (20.26 KB, image/png)
2020-02-14 13:00 UTC, Radim Hrazdil
no flags Details
sata selected (17.97 KB, image/png)
2020-02-14 13:00 UTC, Radim Hrazdil
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4348 0 None closed Bug 1803089: Mark recommended bus types 2020-03-31 06:30:51 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:37:46 UTC

Description Radim Hrazdil 2020-02-14 12:55:44 UTC
Description of problem:

When a user selects an interface that is not recommened, the dropdown doesn't display this intarface as such anymore.

Example:

Virtio is selected (marked with ->), sata is considered not recommened by the used common template:
-> Virtio
sata --- Not Recommended ---
scsi

Now user decides to select sata, dropdownl looks like:
Virtio
-> sata
scsi

When not recommended interface is selected, there is a warning displayed below the dropdown, but the dropdown item doesn't have the --- Not Recommended --- suffix, which seems a bit confusing and inconsistent to me.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
100%

Comment 1 Radim Hrazdil 2020-02-14 13:00:05 UTC
Created attachment 1663112 [details]
Virtio selected

Comment 2 Radim Hrazdil 2020-02-14 13:00:30 UTC
Created attachment 1663113 [details]
sata selected

Comment 3 Matt 2020-02-14 13:17:45 UTC
This makes sense to me. We have on the design side an effort to review the creation flow and make updates around this. I think we can go one step further and mark options as recommended to avoid choosing the wrong option.

Comment 4 Ido Rosenzwig 2020-02-18 10:02:11 UTC
Once the disk bus is chosen from the dropdown list it will not have a `not recommended` label since a warning message will appear below the dropdown, which than the 'not recommended' label will be redundant.

Matt, this is a good idea! I sent a patch to mark only the `recommended` buses instead of the not recommended ones.

Comment 7 Radim Hrazdil 2020-02-27 15:44:07 UTC
Moving back to assigned as the fix hasn't been backported to release-4.4 branch.

Comment 8 Tomas Jelinek 2020-02-28 08:26:40 UTC
retargeting this bug to 4.5 where the fix actually landed and created a 4.4 clone for the backport.

Comment 9 Guohua Ouyang 2020-03-31 06:38:42 UTC
verified on 4.5.0-0.nightly-2020-03-29-224016.

Comment 11 errata-xmlrpc 2020-05-04 11:36:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.