Bug 180311 - Only configure swap devices set for format
Only configure swap devices set for format
Status: CLOSED DUPLICATE of bug 186018
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-06 20:37 EST by Chris Adams
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-29 09:47:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2006-02-06 20:37:16 EST
Anaconda should only configure and use the swap device(s) that are selected for
format during partition setup.  With functioning suspend-to-disk, it won't be
uncommon (especially for developers) to have systems with multiple installs;
suspending one to disk and then booting another one configured to use the same
swap partitions will cause problems.

Right now, anaconda does not provide any way to override swap configuration.  It
always uses all discovered swap partitions as well as any created swap
partitions.  It should either:

- only use swap partitions that are explicitly selected for format
- have a "don't use this for swap" option in the partition setup
Comment 1 Jeremy Katz 2006-02-07 08:47:14 EST
FWIW, suspends won't match our check for swap, so they shouldn't be caught.
Comment 2 David Cantrell 2006-03-29 09:47:42 EST

*** This bug has been marked as a duplicate of 186018 ***

Note You need to log in before you can comment on or make changes to this bug.