Bug 1803135 - Unable to Re-install kubevirt-hyperconverged Operator
Summary: Unable to Re-install kubevirt-hyperconverged Operator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.3.z
Assignee: Vu Dinh
QA Contact: Asher Shoshan
URL:
Whiteboard:
Depends On: 1786471
Blocks: 1803148
TreeView+ depends on / blocked
 
Reported: 2020-02-14 14:46 UTC by Vu Dinh
Modified: 2020-03-24 14:34 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1786471
: 1803148 (view as bug list)
Environment:
Last Closed: 2020-03-24 14:33:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1292 0 None closed [release-4.3] Bug 1803135: fix(packagemanifests): Fix index key func to avoid key collision 2020-06-28 08:39:37 UTC
Red Hat Product Errata RHBA-2020:0858 0 None None None 2020-03-24 14:34:03 UTC

Description Vu Dinh 2020-02-14 14:46:36 UTC
+++ This bug was initially created as a clone of Bug #1786471 +++

Description of problem:
After uninstall the HCO Operator (via UI); the operator is not found in 'operator hub' page anymore.


Version-Release number of selected component (if applicable):

2.2.0

How reproducible:


Steps to Reproduce:
1. Instal HCO
2. Uninstall HCO via UI
3. Try re-Install HCO via UI

Actual results:
HCO not found in operator-hub

Expected results:
To be found

Additional info:

--- Additional comment from Tareq Alayan on 2020-01-01 13:33:13 UTC ---

@Asher can you please try a different operator maybe it is a market place bug?

--- Additional comment from Asher Shoshan on 2020-01-01 14:19:12 UTC ---

Probably it will happen with other operators.
IMHO, the root cause of this behaviour is the flaky command:  "oc get packagemanifest"
From time to time it will not show the package (kubevirt-hyperconverged).
See the other BZ, of arbitrary showing only from one catalogSource.

--- Additional comment from Fabian Deutsch on 2020-01-06 15:14:06 UTC ---

Reinstallation is not a primary path. thus omving it out to 2.3 for now.

--- Additional comment from Fabian Deutsch on 2020-01-06 15:14:43 UTC ---

It also looks to be like an OLM or marketplace bug.

--- Additional comment from Asher Shoshan on 2020-01-07 09:17:50 UTC ---

Agree (OLM issue) - what category to put?

--- Additional comment from Asher Shoshan on 2020-01-29 14:03:29 UTC ---

It happens on other operator as well (see comment #2)

--- Additional comment from Nelly Credi on 2020-01-29 15:28:11 UTC ---

moving to OLM 
please feel free to change if this is not the correct component

--- Additional comment from Vu Dinh on 2020-01-30 04:04:31 UTC ---

Hi,

I'm unable to reproduce this issue on 4.3 and 4.4 cluster. I can't reproduce with other operators either. On 4.3, I can only see 2.1.0 version of HCO so I'm unable to test 2.2.0 version that you listed in this BZ. If this issue only happens with HCO 2.2.0, then I suspect this is not an issue coming from OLM or marketplace.

Thanks,
Vu

--- Additional comment from Asher Shoshan on 2020-01-30 08:35:13 UTC ---

(In reply to Vu Dinh from comment #8)
> Hi,
> 
> I'm unable to reproduce this issue on 4.3 and 4.4 cluster. I can't reproduce
> with other operators either. On 4.3, I can only see 2.1.0 version of HCO so
> I'm unable to test 2.2.0 version that you listed in this BZ. If this issue
> only happens with HCO 2.2.0, then I suspect this is not an issue coming from
> OLM or marketplace.
> 
> Thanks,
> Vu

Hi,

Try add some new operatorSource/catalogSource (redhat-operators-stage or rh-verified-operators) which has the product "kubevirt-hyperconverged" or any.

Then: 
1. oc -n openshift-marketplace get packagemanifests |grep kubevirt --> you'll see only one line from an arbitrary (last?) catalogSource (should be at least 
   two lines one from redhat-operators, and one from the added catalog - this is another BZ).

2. Delete the opsrc created at [1] --> oc -n openshift-marketplace delete opsrc <redhat-operators-stage/rh-verified-operators>  

3. repeat [1] --> you won't see the product at all (and not in UI of course).


To restore back, I found a WA, by deleting opsrc redhat-operators (which is recreated immediately), after a while you'll see the product again from redhat-operators.

--- Additional comment from errata-xmlrpc on 2020-02-14 11:38:46 UTC ---

This bug has been added to advisory RHBA-2019:47983 by OpenShift Release Team Bot (ocp-build/buildvm.openshift.eng.bos.redhat.com@REDHAT.COM)

--- Additional comment from errata-xmlrpc on 2020-02-14 11:38:54 UTC ---

Bug report changed to ON_QA status by Errata System.
A QE request has been submitted for advisory RHBA-2019:47983-01
https://errata.devel.redhat.com/advisory/47983

Comment 1 Asher Shoshan 2020-02-16 09:14:09 UTC
(In reply to Vu Dinh from comment #0)
> +++ This bug was initially created as a clone of Bug #1786471 +++
> 
> Description of problem:
> After uninstall the HCO Operator (via UI); the operator is not found in
> 'operator hub' page anymore.
> 
> 
> Version-Release number of selected component (if applicable):
> 
> 2.2.0
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1. Instal HCO
> 2. Uninstall HCO via UI
> 3. Try re-Install HCO via UI
> 
> Actual results:
> HCO not found in operator-hub
> 
> Expected results:
> To be found
> 
> Additional info:
> 
> --- Additional comment from Tareq Alayan on 2020-01-01 13:33:13 UTC ---
> 
> @Asher can you please try a different operator maybe it is a market place
> bug?
> 
> --- Additional comment from Asher Shoshan on 2020-01-01 14:19:12 UTC ---
> 
> Probably it will happen with other operators.
> IMHO, the root cause of this behaviour is the flaky command:  "oc get
> packagemanifest"
> From time to time it will not show the package (kubevirt-hyperconverged).
> See the other BZ, of arbitrary showing only from one catalogSource.
> 
> --- Additional comment from Fabian Deutsch on 2020-01-06 15:14:06 UTC ---
> 
> Reinstallation is not a primary path. thus omving it out to 2.3 for now.
> 
> --- Additional comment from Fabian Deutsch on 2020-01-06 15:14:43 UTC ---
> 
> It also looks to be like an OLM or marketplace bug.
> 
> --- Additional comment from Asher Shoshan on 2020-01-07 09:17:50 UTC ---
> 
> Agree (OLM issue) - what category to put?
> 
> --- Additional comment from Asher Shoshan on 2020-01-29 14:03:29 UTC ---
> 
> It happens on other operator as well (see comment #2)
> 
> --- Additional comment from Nelly Credi on 2020-01-29 15:28:11 UTC ---
> 
> moving to OLM 
> please feel free to change if this is not the correct component
> 
> --- Additional comment from Vu Dinh on 2020-01-30 04:04:31 UTC ---
> 
> Hi,
> 
> I'm unable to reproduce this issue on 4.3 and 4.4 cluster. I can't reproduce
> with other operators either. On 4.3, I can only see 2.1.0 version of HCO so
> I'm unable to test 2.2.0 version that you listed in this BZ. If this issue
> only happens with HCO 2.2.0, then I suspect this is not an issue coming from
> OLM or marketplace.
> 
> Thanks,
> Vu
> 
> --- Additional comment from Asher Shoshan on 2020-01-30 08:35:13 UTC ---
> 
> (In reply to Vu Dinh from comment #8)
> > Hi,
> > 
> > I'm unable to reproduce this issue on 4.3 and 4.4 cluster. I can't reproduce
> > with other operators either. On 4.3, I can only see 2.1.0 version of HCO so
> > I'm unable to test 2.2.0 version that you listed in this BZ. If this issue
> > only happens with HCO 2.2.0, then I suspect this is not an issue coming from
> > OLM or marketplace.
> > 
> > Thanks,
> > Vu
> 
> Hi,
> 
> Try add some new operatorSource/catalogSource (redhat-operators-stage or
> rh-verified-operators) which has the product "kubevirt-hyperconverged" or
> any.
> 
> Then: 
> 1. oc -n openshift-marketplace get packagemanifests |grep kubevirt -->
> you'll see only one line from an arbitrary (last?) catalogSource (should be
> at least 
>    two lines one from redhat-operators, and one from the added catalog -
> this is another BZ).
> 
> 2. Delete the opsrc created at [1] --> oc -n openshift-marketplace delete
> opsrc <redhat-operators-stage/rh-verified-operators>  
> 
> 3. repeat [1] --> you won't see the product at all (and not in UI of course).
> 
> 
> To restore back, I found a WA, by deleting opsrc redhat-operators (which is
> recreated immediately), after a while you'll see the product again from
> redhat-operators.
> 
> --- Additional comment from errata-xmlrpc on 2020-02-14 11:38:46 UTC ---
> 
> This bug has been added to advisory RHBA-2019:47983 by OpenShift Release
> Team Bot (ocp-build/buildvm.openshift.eng.bos.redhat.com@REDHAT.COM)
> 
> --- Additional comment from errata-xmlrpc on 2020-02-14 11:38:54 UTC ---
> 
> Bug report changed to ON_QA status by Errata System.
> A QE request has been submitted for advisory RHBA-2019:47983-01
> https://errata.devel.redhat.com/advisory/47983

Why is it created (and assigned)  as a clone of Bug #1786471 ?

Comment 9 errata-xmlrpc 2020-03-24 14:33:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0858


Note You need to log in before you can comment on or make changes to this bug.