Bug 1803192 - Monitoring operator should publish sharing-config configmap into openshift-config-managed namespace [NEEDINFO]
Summary: Monitoring operator should publish sharing-config configmap into openshift-co...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Simon Pasquier
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On: 1777486
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-14 16:14 UTC by Jakub Hadvig
Modified: 2020-05-04 11:37 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:36:59 UTC
Target Upstream Version:
spasquie: needinfo? (jhadvig)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 654 None closed Bug 1803192: *: duplicate shared configmap in openshift-config-managed namespace 2020-10-02 11:48:40 UTC
Github openshift console pull 4336 None closed Bug 1803192: use monitoring config from openshift-config-managed namespace 2020-10-02 11:48:40 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:37:27 UTC

Description Jakub Hadvig 2020-02-14 16:14:02 UTC
Description of problem:
Monitoring operator should publish sharing-config configmap into openshift-config-managed namespace, so it's reachable for other components, like console, which needs to access to:
 - alertmanagerURL
 - grafanaURL
 - thanosURL
 - prometheusURL

Version-Release number of selected component (if applicable):
4.4.

How reproducible:
Always


Steps to Reproduce:
1. 
2.
3.

Actual results:
Monitoring operator is publishing sharing-config configmap into openshift-monitoring namespace. If any component needs to get hands on the configmap it needs to get additional RBAC permissions.


Expected results:
Monitoring operator should be publishing sharing-config configmap into openshift-config-managed namespace so no additional RBAC permissions needs to be added to component that needs the configmap.

Additional info:

Comment 4 Jakub Hadvig 2020-02-17 10:14:49 UTC
I would be in favour either for "monitoring" as suggested or maybe "monitoring-shared-config"

Comment 5 Simon Pasquier 2020-02-17 13:45:59 UTC
Moving back to ASSIGNED since the console needs to be updated too.

Comment 9 Junqi Zhao 2020-02-24 03:42:00 UTC
Tested with 4.4.0-0.nightly-2020-02-23-191320
# oc -n openshift-monitoring get configmap sharing-config -oyaml
# oc -n openshift-config-managed get configmap monitoring-shared-config -oyaml

values for alertmanagerURL/grafanaURL/prometheusURL/thanosURL are the same with both commands

Comment 11 errata-xmlrpc 2020-05-04 11:36:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.