Bug 1803213 - Knative resource name in Application group collapsed state card doesn't match design
Summary: Knative resource name in Application group collapsed state card doesn't match...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-14 17:16 UTC by Jeff Phillips
Modified: 2020-05-04 11:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.4.0-0.ci-2020-02-11-035631 Cluster ID: 54dc02ac-aef6-4bf8-ae32-a1442dc77aaa Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.130 Safari/537.36
Last Closed: 2020-05-04 11:36:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4326 None closed Bug 1803213: Update collapsed groups in topology to match designs 2020-04-28 20:21:44 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:37:27 UTC

Description Jeff Phillips 2020-02-14 17:16:21 UTC
Description of problem:

If an application group has Knative service & on collapsing application group, the collapsed app group is expected to display resource name as 'Knative Services' with count as per design. But since we use resource kind as label to display and Knative resources have `kind` value as `Service`, label displayed is 'Service' instead of 'Knative Service'.

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. Add a knative service to a project, and add it to an application grouping
2. From the topology view, select Display and deselect the Application Groupings box 

Actual results:

The group is show collapsed but it shows a count and then Service text

Expected results:

It should show a count, a badge (KSVC) and the text 'Knative Service'


Additional info:

Comment 3 Gajanan More 2020-03-02 11:30:20 UTC
https://issues.redhat.com/browse/ODC-2946 verified by Abhishek K N

Comment 5 errata-xmlrpc 2020-05-04 11:36:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.