Bug 1803232 - Keepalived: Ingress VIP Cluster password collisions
Summary: Keepalived: Ingress VIP Cluster password collisions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Antoni Segura Puimedon
QA Contact: Victor Voronkov
URL:
Whiteboard:
Depends On:
Blocks: 1810996
TreeView+ depends on / blocked
 
Reported: 2020-02-14 18:30 UTC by Antoni Segura Puimedon
Modified: 2020-07-13 17:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The Ingress Virtual IP management configuration was using a fixed string for its password Consequence: If two VRRP keepalived instances in separate clusters had the same Virtual Router ID they would have the same password and potentially join the clusters having the Virtual IP fall where it shouldn't. Fix: Make the password change depending on cluster configuration Result: Different cluster Ingress Virtual IPs will have a different password.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:15:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1380 None closed Bug 1803232: Fixed hardcoded ingress VIP password 2020-08-25 13:47:21 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:15:58 UTC

Description Antoni Segura Puimedon 2020-02-14 18:30:38 UTC
Description of problem:
In case two clusters ended up by chance on the same Ingress virtual router id, there would be membership issues due to the fact that the password is static, in contrast with the other two VIPs, which have it include the cluster name.

Version-Release number of selected component (if applicable): 4.4 ane 4.3


How reproducible: To have the issue you need to deploy two clusters in the same multicast domain in which:
* fletcher8(CLUSTER_A_NAME-vip) = x = fletcher8(CLUSTER_B_NAME)


Steps to Reproduce:
1. Find names that collide under fletcher8
2. Deploy both clusters with the names as above
2. Look at Ingress VIP membership status in keepalived logs (crictl keepalived logs)

Actual results:
Nodes from both clusters are seen as belonging to a single virtual router

Expected results:
Keepalived wrong password messages.


Additional info:
In order to simplify the reproduction, one can just check that the keepalived configuration does not change even if you deploy with different cluster names.

Comment 6 Victor Voronkov 2020-03-18 19:18:40 UTC
in process of deploying OCP 4.5, hope to get it today

Comment 7 Victor Voronkov 2020-03-19 05:53:43 UTC
Verified on 4.5.0-0.nightly-2020-03-18-115438

[core@master-0 ~]$ cat /etc/keepalived/keepalived.conf | grep auth_pass
        auth_pass vvoron-cluster_api_vip
        auth_pass vvoron-cluster_dns_vip
        auth_pass vvoron-cluster_ingress_vip

Comment 9 errata-xmlrpc 2020-07-13 17:15:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.