Bug 18033 - RedHat 7.0 should be recalled.
RedHat 7.0 should be recalled.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-01 17:02 EDT by Kenneth Yeh
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-02 22:35:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenneth Yeh 2000-10-01 17:02:28 EDT
I strongly feel that RedHat7.0 should be recalled.  It is VERY obvious 
that this release was a "rush-job" and the QA quality is terrible.  There 
are some very serious bugs that causes this release to be un-usable and 
even screws up previous working releases in the event of an upgrade.  

If RedHat is even remotely interested in how users preceive the quality of 
its software, they should recall this release and wait a few months to 
work out the bugs before releasing it again.  RedHat 7.0 causes nothing 
but frustration for its users and wastes people's valueable time in trying 
to debug what should have already been fixed during the QA phase.  

It's releases like RedHat 7 that makes people want to switch to other 
distribution's of Linux like Caldera, Turbo, and Mandrake, etc.
Comment 1 Alan Cox 2000-10-01 17:52:38 EDT
If you have real bugs file them. If you bought a copy see the returns policy -
basically if you think
it sucks you can return it
Comment 2 jiefg 2000-10-02 02:32:29 EDT
Alan, is this the way to treat comments ???

The # of bugs reported here, the seriousness of those bugs should goes without
comments. I can understand people being frustrated (hell. I AM !). It is true
that QA missed this release (think of all those users choosing to compile
themselves their apps -- now stuck with a broken c++; it's only an example,
there must be numerous others, but that one is the one that gets me jumping
right now).

I know you're doing hard work - I'm a developper myself at some communications
corp here in Montreal. But I tell ya, I'd get fired if I were to answer the way
you just did.

This thread here will go on numerous web sites, just to show how nice a person
you can be, and how tech people at RH treat users. I'm not saying that all RH
people are like you, but since you replied with a RH.com email address ...

Jeff
Comment 3 Kenneth Yeh 2000-10-02 02:49:18 EDT
Dear Alan and Jeff,

First off, I apologize if anyone working at Redhat took my comments personally.  I was not aiming at Alan or anyone in particular with my comments.  
They are my personal opinions and I needed to vent because I was very frustrated.  However, I do believe I am entitled to my own opinions and my 
opinions are not without merit.  This release of Redhat has much more problems than 6.2 or previous releases.  I have yet to complete an install of 7.0 
that meets my requirements and heck, I've tried over 25 times now on 8 different server configurations so I do hope you can understand my frustrations.

Thank you Jeff for you comments.  I really prefer NOT to switch to another linux distribution as I was very happy with 6.2.  However, doesn't logic point to 
a higher version of linux being more stable?  I was under the assumption that 7.0 would be more stable than 6.2 since it's a higher version.  I guess my 
logic was flawed.  In any case, if I do return my Redhat 7 Professional Server, it will not be because I was angry at Alan...it will be because Redhat 7 
does not meet my requirements and there's no reason for me to upgrade my network of 25 perfectly working servers running 6.2 at my ISP.

Sincerely,

Ken
Comment 4 Need Real Name 2000-10-02 10:31:51 EDT
Dear Alan,

I hope your comment is a result of hard working for more than 30 hours without
any pausing on the
problems in RedHat 7. I hope also that there will be solutions for the biggest
problems in the next
few days. On the other hand the first statement of Ken wold bekome true.

At the last weekend a had install a linux-server at my company. This server had
to work correctly
since today (monday) morning. After working hard on RH7 (installation was ok but
the building of
a new kernel fails) I had to downgrade to RH6.2.

To build a kernel is the most important feature to get a working server running
linux. RedHat had
been my favorite distribution because it was a good solution for the servers I
am responsible for.
This maybe can change in the next few weeks.

Frerich (germany)
Comment 5 Matt Wilson 2000-10-02 22:33:32 EDT
Please read the release notes.  Use kgcc to build kernels.  The new 2.2.18
kernel will automatically choose the right compiler for people who can not
specify "CC=kgcc make bzImage" for themselves.
Comment 6 Matt Wilson 2000-10-02 22:35:12 EDT
Please file any detailed bug reports against the proper Red Hat Linux component
and we will address them.  Please realize that "Red Hat Linux 7 sucks" is NOT a
bug report.  Detailed bug reports and test cases only please.
Comment 7 Dan Browning 2000-10-02 22:35:31 EDT
With as large of a user base as RedHat has, there are bound to be hundreds of 
horrible stories.  I'm not one of them.  I've installed RH7.0 on 4 servers 
now.  (1x486, 1xP133, 1xP3850, 1xdual zeon 500).  My installs have been 
flawless; better than any distro previous (including 6.2).  If everyone shouted 
their successes as loudly as the minority shouts their failures, then RedHat 
would be overwhelmed with positives (and deaf).  Again, this is IMHO, but I 
would like to stand and clap my hands for the RH 7.0 release, no matter what 
SlashDot says.
Comment 8 Sean McPherson 2000-10-02 22:52:41 EDT
People, get a life! My RedHat 7.0 installs have been going well. Sure, there are
some weird things in it, but they're mostly the same things I had plenty of time
to test on Pinstripe. I hadn't read a word about needing to use kgcc to compile
a kernel, but it took me *8 minutes* to find out that's what I needed to do.
I've been using Linux since '92 (Yes, I did DL the sources at 1200 bps, and
started with the compiler up), and by God I read the README files, look at the
INSTALL files, and check the docs. Amazingly, I've had a lot of fun in the last
7 or 8 years, and very FEW cases where I bitched about a 'problem' where it
turned out to not BE a problem.

Now, if people have REAL bug reports, or a SPECIFIC instance where something in
RedHat 7.0 fails, THAT is what I'd like to see. "Recall the product" is such a
blanket statement that no one can possibly take it seriously.

<rant>

I can't feel any sympathy for anyone who attempts to install a brand new release
of software ON A DEADLINE without testing the hell out of it. Pinstripe was out
for how long? If you take a released piece of anything and blindly throw it on a
server expecting it to be up in time for business Monday, you quite frankly
deserve what you get. I'd be willing to take bets that quite a few of the
problems people encounter in cases like that have little to do with the distro,
and a lot to do with a lack of localized testing (testing for the specific
implementation) and a distinct refusal to read the docs first.

RedHat: 7.0 looks pretty good. Yes, there are things to be fixed, but mine's
running well. As I run into BUGS, I'll post them here, hopefully with some
decent background info and a description of the environment, along with info on
whether it's reproduceable. Oh Goodness, I must have gotten the idea to include
that info from READING THE DOCUMENTATION FOR BUGZILLA!!!

</rant>
Comment 9 Henri Schlereth 2000-10-02 23:57:58 EDT
Goodness. First time I ever saw a slashdotted bug report.<heh> So any one looking at this report, the number of bugs for 
7.0 that are new/open are 149. The rest of the other 2.500 bugs are spread out over previous releases and beta
test releases.

Have a nice planetary half-rotation.

Henri J. Schlereth
RedHat Beta Test Team.

P.S. if you can't tell RedHat what's wrong, how do you expect them to fix it?
Comment 10 Pat Gaddis 2000-10-03 01:39:02 EDT
Beside the slight problem getting a new kernel to compile (forgive me if I 
didn't see any notes about using kgcc, but where is there docs on this?), I've 
had absolutely no problem with RH7.  Granted, I don't foresee using RH7.x on 
any of my servers until 7.1 at least, but as my desktop workstation, my 
experience has been what it should have been-- a nice improvement over 6.x.
Comment 11 Idcmp 2000-10-03 02:36:27 EDT
I've installed Red Hat 7.0 on an IBM a20m ThinkPad, and upgraded the kernel to
2.4.0-test8.  The install was flawless, and after getting the right things in
2.4.0 working, I've got a fully function laptop with power management and the
works.

If this is "horror", then I guess I'm a fan of the genre.

Comment 12 tannhaus 2000-10-03 03:12:10 EDT
Ummm...I know that during the install I saw that about kgcc...maybe I just
looked at the packages I installed before I installed them, but I did see that
somewhere.  All in all I've only found two "bugs" and one was solved by common
sense.
Comment 13 Kenneth Yeh 2000-10-03 03:58:57 EDT
To all:

I'm happy that you guys aren't having problems with Redhat 7.  However, I am and I have a right to express my opinions.  I have been running linux on my 
old old 386SX33 since the 0.98 release of the linux kernel so I'd like to think I know a few things about linux.  However, this release of Redhat is nothing 
but trouble.  I posted my gripe about Redhat 7 after posting 3 other bugs which I put as very high priority for me.  These bugs were closed and flagged as 
"NOTABUG" or flagged as duplicates.  Just to give you guys a taste, one of the bugs pretains to not being able to run DNSCONF or configure my apache 
web server using the LINUXCONF tool.  Yes, I _can_ configure my apache by hand and I _can_ configure my domain name server by hand but I prefer to 
use the LINUXCONF tool because that's what I bought the Redhat 7 for!  If I wanted to do all these by hand, why did I bother spending $200+ for 
Redhat?

The response I got from Redhat about the DNSCONF/APACHE CONF/etc bug was that "these have been disabled due to problems that cannot be fixed" 
and thus, NOT-A-BUG.  These tools were working perfectly in 6.2 and before...and in 7.0, it's not.  HELLO?? 

Anyways, I find it very disturbing that Redhat is making people who pay for their software waste their time doing the QA phase for them.  Some of the 
bugs are outright blatant and should have been caught WAY before the release.  Others are even "known" and yet, they still proceed with the release of 
Redhat 7.  That's the most disturbing part of it all...
Comment 14 Need Real Name 2000-10-03 04:30:17 EDT
I think it should be better to tell my experience _after_ have installed the
RedHat Linux 7.0, and be shure that I will post good or bad comments about it
when finally I will upgrade the 6.2 to the 7.0.

The reason for that post is that I have not read about serious bugs that keeps
me away from the upgrade!
It is true that the gcc (as Gnu Compiler Collection in its whole meaning, not
only the C compiler) is not the best choice for developers (as I am) because the
version here included is too unstable, you can find that even in the gcc-bugs
lists, but it is simple for a developer to downgrade to the "stable" version
(note that even the 2.95.2 have serious bugs, but not so serious to avoid it!).

You as a System Adm. should never change a very stable and tested release to a
new and maybe unstable release, it is the basics to learn and you can find it in
manuals!

Even so, you can learn the best think to do to secure a server is to buil a
distro from scratch, based on an already installed distro, like RedHat Linux,
but changing everything and without the gcc installed (a server should not have
a compiler and other things that a cracker can use to force it!).
See http://www.linuxfromscratch.org/ for example.

Another bug could be the wrong permissions for MySQL, it is simply a matter of
change them, or upgrading the rpm to a new and fully operational one.

I hope this will be the last post that do not talk about real bugs, because bugs
are inside RedHat Linux, as It is obvious, Debian have a lot of bugs, Mandrake
have a lot of bugs, even Slackware (the most stable and secure distro as is in
my _own_ opinions) have some bugs, and you cannot pretend to free the world from
them ;)

I'm waiting for the RedHat Linux 7.0, hoping the bugs we submit will give a
great 7.1 to the world.

-------
neugens
-------

Linux Tester
Comment 15 Need Real Name 2000-10-03 11:01:15 EDT
I think that anybody who has serious gripes needs to remember that RH has been 
the best distro for quite some time, as either a server or a workstaion. the 
versatility of the OS as well as the impact RPM had in the developer world is 
very large plus. Alan whos comments seem quite ,ignornant, is only lashing out 
as a result of frustration, I would do the same, he os ony defending his 
product that he knows so well and works with day to day, its emotional, I 
understand. I think what he is saying here is, maybe it just isnt for you. I 
thought part of the Linux experience was making it do what you wanted it to 
do,,, well I am compileing my software with out any dificulities, spend less 
time bitching and fix it your self. 
I forgive RedHat for releasing an OS before its been properly testes, its 
economics and RH wouldnt be here if it was not for economics, this whole 
industry is economicaly driven, and when you got it for free, dont bitch.
Comment 16 Need Real Name 2000-10-03 15:25:11 EDT
Something I've been thinking about for a long time, and which it might be
appropriate to mention
now...

I have to worry about the patch level on close to a thousand Sun/Solaris
machines.  It isn't too hard,
since Sun bundles their most important patches for each version into
"recommended patch
clusters."  You download one big file, and start it installing.  Patches that
have already been
installed fail without making problems, and in a little while you have
effortlessly brought your system
current with every significant patch that was released as of the day before.

Why don't you folks do this?  Or do you somewhere, and I just haven't heard
about it yet?
Comment 17 Christof Ameye 2000-10-03 16:33:01 EDT
I had a good experience installing RedHat 7.0. Except for one bug which I
thought would be no problem at all: the 1024 cylinder limit for lilo. After the
installation I had to boot up with a floppy, but after fixing an entry in
lilo.conf and running lilo, the problem was solved. 

I can say you: I have been working with RedHat quite a long time and a few
months ago I tried Mandrake, which was really a bad experience: It was really
buggy: nothing but troubles and often my system locked up, I think they were
using lots of stuff that were not tested enough. I came back to RedHat with this
7.0 and I have absolutely no regret. I hope I don't have to meet any very
serious and anoing bug.
Comment 18 Need Real Name 2000-10-03 16:49:09 EDT
hmmmm I just when to bugzilla to check out the bugs (link from /.)
After selecting 'Query existing bug reports' under the 'Bug Options' I was 
brought to http://bugzilla.redhat.com/bugzilla/query.cgi. 

When clicking to select a Product under 'Product Information' I get some errors 
(below).
Wouldn't it be an idea to get your bug report pages working?

Dave <cosmo@skynet.ie.nospam>

JavaScript Error:
http://bugzilla.redhat.com/bugzilla/query.cgi, line 76:

selectProduct is not defined. 
JavaScript Error:
http://bugzilla.redhat.com/bugzilla/query.cgi, line 76:

selectProduct is not defined. 
JavaScript Error:
http://bugzilla.redhat.com/bugzilla/query.cgi, line 76:

selectProduct is not defined. 
JavaScript Error:
http://bugzilla.redhat.com/bugzilla/query.cgi, line 76:

selectProduct is not defined.
Comment 19 gregg 2000-10-21 17:18:58 EDT
while i personally haven't had any problems with the 7.0 (although i haven't 
tried to recompile the kernel yet), i can understand some of this.  i purchased 
redhat 5.0 when it was brand new and the one and only time i attempted to use 
redhat's 'technical support', i got a message back stating that i 
should 'choose another distribution'.  it's disheartening to see that they have 
not changed their ways.

Note You need to log in before you can comment on or make changes to this bug.